WordPress.org

Support

Support » Installation » [Resolved] XAMPP phpMyAdmin login info ??

[Resolved] XAMPP phpMyAdmin login info ??

  • Hi. I just downloaded, installed and have the Apache & mysql services running on my box but even though I am looking at the ID & PW in the WinMySQLadmin .ini file (that came with XAMPP), those are not working for me when trying to login to phpMyAdmin as discussed 3/4’s of the way down this page:
    http://www.tamba2.org.uk/wordpress/xampp/.

    I have been to their homesite (http://www.phpmyadmin.net/home_page/index.php) as well as to Sourceforge for questions but have never heard back from either one of them. Surely there is an easy way to get into phpMyAdmin that I’m just not aware of, can someone help me out here? TIA.

    Oh yeah, I haven’t heard back from the XAMPP people either so 3 strikes, I’m out lol.

Viewing 15 replies - 1 through 15 (of 42 total)
  • I reloaded everything, apparently my FF cookie was pulling something else in that wouldn’t work… I uninstalled, reloaded and can now get in. Thx anyway.

    (Please disregard the earlier two statements this thread, but I still can’t get my WP blog up in XAMPP)

    No matter how many times I do it according to the instructions here http://www.tamba2.org.uk/wordpress/xampp/, when I load the URL they mention: http://localhost/wordpress/wp-admin/install.php, all I get is a 404 NOT FOUND.

    I am using this in the config file because that is what we are told to use (and because it is the only login info I have anyway):

    define(‘DB_NAME’, ‘wordpress’); // The name of the database
    define(‘DB_USER’, ‘root’); // Your MySQL username
    define(‘DB_PASSWORD’, ”); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    As usual, any help is appreciated since I just wasted the better part of 24 hrs trying to install WAMP on my machine individually (not even wanting to get to the part where I would have to load the WP tables to mySQLAdmin lol) so while XAMPP certainly sounds alot easier, all I get is a 404 when doing what the instructions say.

    So xampp is running successfully on your box, good!

    Your WordPress folder is where? On my machine it’s here:
    c:xampphtdocswordpress

    I can get into xampp and ultimately phpMyAdmin with this:
    http://127.0.0.1/xampp/index.php

    I’ve always accessed phpmyadmin as “localhost/phpmyadmin/” in the browser addy bar (no quotes around string). My username has always been “root” (no quotes), and at first you’ll get an error message about root with no password; use the available tools in phpmyadmin to set a password for root to use from then on….

    I can get into phpMyAdmin fine now but I’m trying to get my WP blog up, which is why I posted all the login info but if you want to point me to where I need to go to for direction on loading the WP tables to the XAMPP mySQLAdmin db I created, that would be great too (for use after I finally get WP up lol). Basically, I’m trying to use XAMPP to get my blog up but the sparse directions at the site I mentioned above don’t nearly cover enuff for my thick head (especially when doing it gives me a 404). TIA

    All you should have to do at this point then is put “localhost/path*to*wp/wp-admin/install.php” in the browser addy bar….

    damn that sounded so good when you said it too, I was making up your dinner order…

    I tried this but no joy, still getting 404 (it added the %20)

    http://localhost/Program%20Files/xampp/htdocs/WP2.0/wp-admin/install.php

    and yes, the localhost link at the bottom takes me to the XAMPP screen which is fine but…

    I took XAMPP’s default settings, everybody has a space between Program and Files so ??

    How is your’s set vkaryl?

    EDIT: attempting move to my root now…

    no joy here either

    http://localhost/xampp/htdocs/WP2.0/wp-admin/install.php

    any suggestions? already way passed the site description but I’d just be happy to get it working

    Normally it should be:
    http://localhost/WP2.0/wp-admin/install.php
    supposed WP is installed in a directory “WP2.0” – not sure the dot in the folder name is a healthy thing, though. I always avoid that kind of names, and use things like “wp_20”.

    Weeeelllll…. as per normal, I don’t ever do things “normally”….

    XAMPP is installed where it wanted to install 5 years ago or so: c:\apachefriends\xampp\xampp\. I tried once to move it, it borked, I put it back.

    Only thing I use it for is designing websites, and that’s the whole of my e:\ drive, so I don’t use htdocs.

    So server root is c:\ (the entire drive, just in case – at one point in the intervening years, I had to change it to that to make it work, so I’ve never changed it back [if it ain’t broke DON’T FIX IT!]) and my document root is e:\. My httpd.conf file is vanilla – I didn’t have to do anything to it.

    I don’t think that’s going to help you much. And since I don’t have a setup like yours, I doubt I’ve much more info you can use.

    Did you dig around on the English forum at apachefriends? There could I suppose be something you need to customise in the httpd.conf file….

    <EDIT>: I didn’t see English the other day (and still haven’t heard back from them, will go back now, ARGH! Thx for trying guys. (I wish the tamba site was current and correct, after all, I’m just doing what it said)<EDIT>

    But how does that reference XAMPP at all Moshu?

    anyway, I tried this and still get a 404 (after changing folder name)

    http://localhost/WP/wp-admin/install.php and
    http://localhost/wordpress/wp-admin/install.php

    (which is exactly how they have it on their website, no joy)

    EDIT: guess I didn’t go far enuff down when I kept seeing non-English, typical American lol

    http://www.apachefriends.org/f/

    Mark (podz)

    @podz

    Support Maven

    I wrote that xampp stuff so I’ll take the blame 🙂

    Can we go back to the start ?
    C:/xampp/htdocs/wordpress/
    is where you have all your files ?
    and they follow as such:
    C:/xampp/htdocs/wordpress/index.php
    C:/xampp/htdocs/wordpress/wp-content/
    C:/xampp/htdocs/wordpress/wp-admin/
    C:/xampp/htdocs/wordpress/wp-includes/
    and a lot of other files.
    Is that correct ?
    Or are you certain that you have the wordpress folder inside the htdocs folder ?

    You have to tell apache where to find server root and doc root – in the httpd.conf which is found in the xampp\apache\conf folder. MAKE A BACKUP OF IT before you edit it!

    (I should have said above that the only changes I made to httpd.conf were server root and document root – sorry for that bit of misinfo….)

    About line 57, find:

    ServerRoot “0:/apache” [this is what my default one shows, yours may vary]

    Change this to read:

    ServerRoot “wherever apache is installed” [in my case, this is ServerRoot “c:/”]

    Around line 228 find:

    DocumentRoot “O:/apache/htdocs” [same caveat entered above]

    Change it to read:

    DocumentRoot “entire path to wherever your htdocs is” [mine reads DocumentRoot “e:/AWebsites” – as I said, I’m not “normal”, but fortunately apache doesn’t care….]

    podz, everyway I posted above is the way I tried it at that time, including http://localhost/xampp/htdocs/WP2.0/wp-admin/install.php

    but no matter now, I deleted it all and uninstalled (in case renaming wp2.0 to wp then wordpress (as tamba suggest) may have screwed up my linkage, I was ready to fish their forum when I came back to let vkaryl know I found the English part but since I’m here, I’ll read this first…

    read it, starting over podz, planning on putting at root, just like you have in your post (although I don’t recall the option for me to edit, will check)

    vkaryl, thx will use your tips too of course

    I already have the zips so if I shouldn’t attempt the root location, let me know podz Thx both.

    Mark (podz)

    @podz

    Support Maven

    Installing to C: is fine – the screenshots you see are from when I did my install.

    You can get all the way to this part of the guide:
    “After you have clicked your language and entered the program, click phpMyAdmin.”
    and after that it all goes wrong ?

    You can always download the 29meg Installer version and unzip that to C:

    It doesn’t have to be at root though – almost anywhere will do, so long as you put your files into the ‘htdocs’ directory.

    truthfully, I wasn’t even looking at your screenshots, just following the install instructions

    I was using the full package though, not the LITE version which I wouldn’t think would affect anything

    my problem is come WP install time after creating the db (with no tables in it, so how do they get created?), yes I put the wp folder inside the htdocs folder but all I get is a 403 coming out… I need to incorporate V’s tips though and see if that helps, was waiting for anything else you might have to add, thx so much guys, gotta go get some Friday night sushi with my wife, my fav, peace!

    btw: last look at my bloglines account, I was at 900+ feeds unread, I’m not even going there until I get this straight once and for all, meaning I am my own host!

    Vkaryl, just tried to leave a msg in the “English” section but all the instructions are french or whatever lol… besides, they never did answer my registration request ARGH, love the support lol, oh yeah sushi, l8tr

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘[Resolved] XAMPP phpMyAdmin login info ??’ is closed to new replies.