Support » Plugin: Multisite Language Switcher » XAMPP change port

  • Resolved marcusasiabc

    (@marcusasiabc)


    This question may sound a bit off-topic.

    I have testing site locally running on XAMPP, with MLS enabled for 1 translation.

    After I have updated the XAMPP Apache from listening port 80 to port 8080. I cannot enter the site. So, I access the DB, to wp_options and wp_2_options table, update the field “siteurl” and “home” to http://localhost:8080/SITENAME and http://localhost:8080/SITENAME/2ND-LANG, I still can’t access to the site.

    If it is not a multi-site setup, the above change in wp_options table can fix the problem. But, it is not my case here.

    May I have any advice here what entry or config I have missed to change so that I can fix the problem?

    Any comment is welcome. Many thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Dennis Ploetner

    (@realloc)

    I have no idea what the problem is here. The Multisite Language Switcher works only in a multisite env and would not change the main settings for the installations. Try to refresh the permalinks or move the folder of the plugin to another name… this should do the trick because it deactivates the plugin.

    If not I guess this has to do with some .htaccess …

    I’m still finding solution. If anyone gets this problem, just go to wp-config.php and find define('MULTISITE', false);define('SUBDOMAIN_INSTALL', false);, make sure these values are false

    The solution is here: First, look for the tables

    • wp_blogs
    • wp_site
    • wp_options
    • wp_2_options (it is the second network)

    Change these to your new local url. i.e. from localhost to localhost:888 (example):

    • In wp_blogs these are all the entries in the domain column
    • In wp_site this is the entry under the domain column
    • In wp_options this is the option_value corresponding to the option_name of siteurl and home
    Plugin Author Dennis Ploetner

    (@realloc)

    Ok, excellent!

    Thanks for help

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘XAMPP change port’ is closed to new replies.