Support » Installing WordPress » Xampp and WordPress – doesn’t work….

  • Hello!

    I am trying to setup WordPress on my local machine to create the whole template thing. I am fairly new to mysql and that stuff because I studied design and honestly don’t really know what I am doing.

    I downloaded Xampp 1.4.4 and let the installation run. After that I startet xampp with the startmenu link “xampp basic start” and copied the wordpress directory in the xampp dirctory.

    Than I created a mysql database through the xampp configuration html site in firefox. I have called this database “wordpress”.

    After that I tried to edit the wp-config.php of wordpress. The database name is of course wordpress. I think the mysql username is after a fresh installation of xampp ‘root’ and there is no password. I entered both into the file, saved it and tried to run the wp-install.php.

    But I get hundreds of errors. First of all it says that it cannot find the wp-config.php and than I get hundreads of error like this one throught the text:

    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $wpdb->users”); if ($installed) die(__(‘

    What did I do wrong and how can I fix this?
    Thanks a lot

Viewing 8 replies - 1 through 8 (of 8 total)
  • Mark (podz)


    Support Maven

    Is the wordpress directory in the ‘htdocs’ ?

    As Podz stated above, put the WP directory in the htdocs folder.
    What I did: Opened Win Explorer and copied the downloaded (and unzipped:) WP files in a directory “wordpress” under the htdocs.
    AFter that opened the browser and typed in the address:

    Sorry I forget to write that. Yes it is. I have downloaded wordpress 1.2.1 because I thought maybe it’s because of the latest version, but I get even more errors now.

    I think it has something to do with the mysql database and the mysql username and pass because besides all weird errors the installation page always complains about a missing wp-config.php file. Btw. when I try to set it up through the web interface noting happens at all.

    Any ideas?

    Don’t mess with different versions – they have different database table structure.
    Normally the user is root by default for the db and no password at the initial install – unless you changed that.
    If it’s looking for the config file, it means it isn’t in the right place… or it was misnamed…

    I have the same xampp distro. It’s on c: which is also set as server root. My document root is set as d: which is where my data lives. In order to manipulate your database info, you need to enter in a browser addy window http://localhost/phpmyadmin. There will be a dropdown in the left sidebar which will have a list of databases. In the right side of the page will be some options. In order to set up a new user for the database in question you’ll need to go to “privileges” and setup a new user. Just follow the steps. Don’t use your “root” user even on a home setup….

    Mark (podz)


    Support Maven

    Did you download the Installer version ?

    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', ''); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    those values should work.

    “Than I created a mysql database through the xampp configuration html site in firefox”
    You opened xampp, clicked phpmyadmin on the left and then created a database ?

    It does look like either the files are in the wrong place or they are downloading / unzipping strangely.

    Thanks guys!

    It works now. I don’t know what it was, but I have restarted my machine twice and manually started the apache server and the mysql database and could finally run the setup.


    can someone tell me what this means, (using xampp):

    Warning: file(C:\apachefriends\xampp\htdocs\wordpress/) [function.file]: failed to open stream: Permission denied in C:\apachefriends\xampp\htdocs\wordpress\wp-admin\admin-functions.php on line 938

    Warning: implode() [function.implode]: Bad arguments. in C:\apachefriends\xampp\htdocs\wordpress\wp-admin\admin-functions.php on line 938

    i was really hoping to not have perm problems, but they seem to be in my blood.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Xampp and WordPress – doesn’t work….’ is closed to new replies.