Support » Plugin: Affiliate Hoover » Xampp and Affiliate Hoover

  • Resolved salmonbones

    (@salmonbones)


    After using Affiliate hoover on a good, up to date host I found it works perfectly for my needs.

    However when taking it into my test area of my computer running xampp, I cannot activate the plugin, I get this error:-

    Fatal error: Class ‘Config\Configuration’ not found in C:\xampp\htdocs\wp-content\plugins\affiliate-hoover\home.php on line 35

    I don’t think this is a version error of php, because it is running version 5.4.7

    I have now started to tinker with php.ini because I was getting timeouts running this plugin for large feeds, but I am not quite sure what this problem is, if anyone has any advice?

    http://wordpress.org/extend/plugins/affiliate-hoover/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter salmonbones

    (@salmonbones)

    I may have resolved this,

    I changed the include once in home.php to ‘c:\xampp\htdocs\wp-content\plugins\affiliate-hoover\config.php’ and it activated…..hopefully no more issues.

    I realise this is not something you could change for your package though, nor have I probably used the best method to fix this for my somewhat unique issue.

    Thread Starter salmonbones

    (@salmonbones)

    Nope, still doesn’t work.

    oh well.

    Thread Starter salmonbones

    (@salmonbones)

    Ok, I 100% have resolved this, which is not an issue with this plugin, but how xammp works.

    The solution involves changing config.php to another name, then editing home.php to reflect that change, then copying the whole directory into the pear directory of php in xampp.

    I won’t pretend to know why this worked but once I figured out that this plugin was looking inside a file called config.php in the pear directory and not the one included in this package, this work around struck me as a possibility and I have now got this plugin working in this environment.

    Thanks,
    Love this plugin!

    Good thing yours is already resolve i also had the same problem with the plugin not activating.. i would try your solution on this and see if it would works.. thanks..

    tried the fixed above! already activated the plugin seems to be working ok!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Xampp and Affiliate Hoover’ is closed to new replies.