• TheIcon

    (@webmaestro66)


    Hello, I am trying ti install wordpress on XAMPP, I keep getting a messsage, Database connection error, I know this is a common problem, I have set the DB name, and checked the php config file and it all matches up so what is the problem?, any help would be very much appreciated!!!!. P.S I never get to the window where it takes you to wordpress!!!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • I can’t be sure, but this page has one possible solution:
    http://www.kajabity.com/2012/10/error-establishing-a-database-connection-with-xamp-mysql-and-wordpress/

    Can you use phpMyAdmin? That means it’s up and running but that particular user can’t connect.

    TheIcon

    (@webmaestro66)

    Thank you very much for the reply, very much appreciated!, I have set the host to – localhost! but it still won’t work, really tearing my hair out over this.

    If this is a fresh install you might try renaming config.php to config-1.php.

    That will restart the install process. If you haven’t created anything yet, you have nothing to lose.

    @webmaestro66

    The default database user name and password for XAMPP are:

    User: rooot
    Password: <none> … do not enter ANYTHING for this value.

    Your wp-config should look like this:

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'your-db-name');
    
    /** MySQL database username */
    define('DB_USER', 'root');
    
    /** MySQL database password */
    define('DB_PASSWORD', '');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Cheers!
    Lyle

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.