Support » Localhost Installs » XAMMP WPMU Sub-blog issue

  • Resolved peterson.julia


    Hello everybody,
    On my Win7 I installed XAMPP with WPMU installation which all went ok, but when I created a sub-blog http://localhost/mainblog/subblog the sub-blog is displayed but HTML only. There is not styling at all and when I click on admin menu I get Access forbidden! 403 error.

    Anybody has a clue what it can be?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I find in xampp error log this xampp

    The given path is misformatted or contained invalid characters: [client

    I’ve got the same problem.
    1) The main site word fine, and his dashboard.
    2) the other sites shows only html without styles, and his dashboard show an Error 403. The problem with styles (and js files) is the browser don’t find some files, like style.css. In my case the file “http://localhost/wordpress3/david2/wp-content/themes/twentytwelve/style.css?ver=3.5” returns an Error 403 . “david2” is a site.

    I don’t undertand the problem 🙁

    My system:
    windows vista, XAMPP-PORTABLE 1.8.1, wordpress 3.5

    My wordpress installation is in the folder “wordpress3”. System folder is “C:\xampp-portable\htdocs\wordpress3”

    My .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress3/
    RewriteRule ^index\.php$ - [L]
    # uploaded ?les
    RewriteRule ^([_0-9a-zA-Z-]+/)??les/(.+) wp-includes/ms-?les.php??le=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) C:\xampp-portable\htdocs\wordpress3/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ C:\xampp-portable\htdocs\wordpress3/$2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Like Julia, my apache error log has entries like this:

    [Fri Dec 28 21:41:46.912400 2012] [core:error] [pid 6704:tid 1636] (20024)The given path is misformatted or contained invalid characters: [client ::1:52886] AH00127: Cannot map GET /wordpress3/david2/wp-admin/ HTTP/1.1 to file

    I’ve tested the same configuration in a real hosting and the result have been the same. the problem is not localhost.

    someone can help?

    Yes, I’ve been fighting with this issue for a few days as well. I am tempted to go back to 3.4 for my test bed, but not sure that works either. What’s interesting in the error message is the “cannot map GET…” sentence. Is this coming from the database? There is no subfolder in my XAMMP tree (nor would I necessarily expect one).

    One possible piece of the puzzle for those who may know more about Apache servers: the Apache Wiki “List of Errors” page says this is what AH00127 is: “Buggy authn provider failed to set user for %s”

    Another possible piece of the puzzle: This thread from StackOverflow suggests that changing a setting in the “new XAMMP Security Concept” section of xampp-httpd.conf may help too: “I am guessing it has something to do with the new XAMPP Security Concept. My best answer to this would be to change the Deny to Allow in that section of your httpd-xampp.conf file.”

    I hope this helps others troubleshoot.

    I removed new xammp security and the problem is not solved.

    On the other hand, i’ve got the same problem in a hosting not xammp.
    the problem may be other 🙁

    thank’s for the idea 🙂


    the problem was the code wordpress give me to .htaccess was WRONG

    This lines:

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) C:\xampp-portable\htdocs\wordpress3/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ C:\xampp-portable\htdocs\wordpress3/$2 [L]

    contains absolute path, and this is the error!

    the correct lines to .htaccess are:

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) /wordpress3/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ /wordpress3/$2 [L]

    The same error was in linux installation. absolute path was the error, and relative path to server root was the solution!

    May be this have to be corrected in wordpress network!


    You the best! It does work!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘XAMMP WPMU Sub-blog issue’ is closed to new replies.