WordPress.org

Support

Support » Plugins and Hacks » Widget Content Blocks » [Resolved] WYSIWYG Widgets not working, even with all other plugins de-activated.

[Resolved] WYSIWYG Widgets not working, even with all other plugins de-activated.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Sorry, I realise that was a bit vague…

    My exact problem:

    – Visual tab is greyed out
    – After inserting image, HTML tab still empty (but when I send to widget, it is there in a p tag)
    – Typing into the HTML tab and sending to widget doesn’t do anything, nor does adding a link etc etc.
    – Tried in Firefox and Chrome

    Thanks,
    Caroline

    Further to my monologue…

    It works sometimes, but not always! Refreshing the backend (/wp-admin/widgets.php) seems to help.

    We are seeing the same problem with WordPress 3.2.1 and both 1.0.7 and 1.0.6 of the plugin.

    I just downloaded it and I get the popup but when I click on Send to Widget, nothing appears. Any ideas?

    Bodetti

    @developing-wordpress

    I have tested this out there appears to be some issue between the parsing of java script, for successive instantiation, not sure of the exact issue, tested in crome, safari, firefox, IE, different issues for all those browsers, too many to list, I like the way the editor is presented, (modal dialog) it just sadly is not working.

    do you know of any other wysiwyg editors for text widgets? I have not seen one that works!

    I have the same issue here. Would be great if this could be fixed soon.

    Plugin Author Danny van Kooten

    @dvankooten

    Hi all,

    Sorry for the late response but I just wanted to give you a quick heads up that I’ve just updated WYSIWYG Widgets to version 1.1, which adresses most of the known issues.

    Give it a try and let me know what you think!

    http://wordpress.org/extend/plugins/wysiwyg-widgets/

    Kind regards,

    Danny

    Hi Danny,

    I just want to say what your plugin offers should be built-in to WordPress. These latest changes show good improvement. Thanks for the update!

    CarolineElisa

    @carolineelisa

    Hi Danny, thanks for updating the plugin!

    I can confirm that it is almost working for me.

    The only problem I have come across is that when I add a link and select ‘open in a new window/tab’ then hit ‘Add link’, the page refreshes and I lose my widget content.

    Plugin Author Danny van Kooten

    @dvankooten

    Hi CarolineElisa,

    Hmm, strange. I haven’t experienced that issue so far. Could you please provide me with some more details so I can replicate the bug.

    – What browser are you running (+ version)?
    – Which version of WP?
    – How many WYSIWYG Widgets were opened (in other words: how many visual editors where there on your sidebar when this problem happened)

    It would be wonderful if you could answer the above questions so I can replicate and fix the bug. 🙂

    CarolineElisa

    @carolineelisa

    Thanks for the rapid response!

    – Firefox 8 for Mac
    – WP 3.2.1
    – I have 3 WYSIWYG widgets, with just 1 open

    To clarify, it happens when I add a second link in a widget. The first time is fine.

    Plugin Author Danny van Kooten

    @dvankooten

    Thanks, didn’t read well enough before posting but figured it out shortly after. Just fixed it, WYSIWYG Widgets version 1.1.1 should be in the WP Repository in a few minutes!

    Let me know if it works for you too. 🙂

    seozones

    @seozones

    okay great. Thanks Danny, looking forward to seeing it work!

    jskspirit

    @jskspirit

    The dialogue box that opens to insert/edit a link does not work (box doesn’t fully load). Sorry – but great idea.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] WYSIWYG Widgets not working, even with all other plugins de-activated.’ is closed to new replies.
Skip to toolbar