Support » Fixing WordPress » WYSIWYG Toolbar Not Displaying

  • Hi All, just did my first install of WP a couple of hours ago. It seems to be working great, but my WYSIWYG toolbar isn’t displaying. The functionality seems to be there, I can use the functions if I can find them, but the icons (bold, center text, link, etc) aren’t displaying. I checked the directory structure, and the paths seem to be correct, and the images are in their directory. I also tried both Firefox and IE. Any ideas? Since its a new install should I delete it and try again?

    Chris (Lenwood)

Viewing 7 replies - 1 through 7 (of 7 total)
  • There’s two places to enable the WYSIWYG editor. One is in Writing options and the other is in your User profile. Make the settings in those two places match and see if that fixes things. I had the opposite problem as you, I didn’t want the editor and couldn’t get rid of it… until I discovered there were two places for this setting.

    Thanks for your reply Aine. I checked the settings. The writing options is set correctly, but I couldn’t find the setting within my user profile.

    I didn’t say this in my first post, but as the page loads I see the broken image icons, and they disappear one by one, and I’m left with a toolbar that’s just a couple of pixels wide, so I can’t see anything in it at all.

    After tinkering with my site for a while, I realize that NONE of my images are showing, on ANY page. Blog, admin, sidebar, no images are showing.

    I’m pretty sure this has to do with where I have it installed, but I’m not sure how to fix it.

    I’m running a b2evo site on my main domain, and I’m thinking of switching to WP, so I’ve installed it on another domain, which points to a subfolder. My thought behind this is that I want to get comfortable with WP and configure it the way I need it before I implement it on my main blog.

    WP works perfectly here, all of my links and pages work great. But no images are showing anywhere. But, if I access the folder directly, then some images load, and some don’t.

    Any thoughts on how to get WP to work here without hacking it to smithereens? Once I get it configured, I’d like to install it on my main domain, import all of my posts & comments, then apply all of my customization.

    Thanks in advance. If this has been answered somewhere else, feel free to just post the link. I did a search, and didn’t find anything helpful.

    I found the problem and fixed it. I had blocked access to my images and folders to prevent bandwidth theft. Once I gave permission to this new domain, everything started working. Just goes to show you, if you make security tools simple enough to use dopes like me will lock ourselves out of everything.

    I had the same problem for the same reason (image access blocked). I also couldn’t select a category when posting because the + images weren’t showing up in the right nav bar. Something should be done to prevent this from breaking the program.

    I am having the same exact issue. What do you mean when you say that you blocked access to your images? How did you unblock the access?

    I agree that this was a pain. Not sure what could be done to prevent this, because its related to security. ‘Fixing’ it would mean that anyone could link directly to your images, effectively stealing bandwidth.

    The thing that tipped me off was that NO images were displaying on my site. And when I checked the stats for my primary blog I had dozens of hits from my WP blog, and there are no links connecting the two.

    The fix for me was to add my WP domain to the list of approved domains and ba-da-bing everything worked perfectly. In my webhost’s CPanel there’s a tool called Hotlink Protection which prevents other sites from linking directly to my images and media files.

    I’m not sure if that’ll help you or not, because my webhost uses a customized version of CPanel, and they’ve added a lot of features. If they do have it, it’ll be in the website tools section.

    If you’re still stuck, post your URL and I’ll try to help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WYSIWYG Toolbar Not Displaying’ is closed to new replies.