WordPress.org

Forums

[resolved] WYSIWYG TinyMCE not working? (7 posts)

  1. TheInfernoSin
    Member
    Posted 6 years ago #

    For some reason my TinyMCE is not working?

    Screeny: http://letstalkdev.com/wp25error.PNG

    I tried reuploading the default theme, nothing.

  2. sacredpath
    Moderator
    Posted 6 years ago #

    Check under users > your profile and make certain the checkbox at "use visual rich text editor" is selected and then click "update profile" at the bottom of that page.

  3. TheInfernoSin
    Member
    Posted 6 years ago #

    Thank you :) solved. I just did some searching for like 30 mins and forgot about this topic yet I found the same answer.

  4. sacredpath
    Moderator
    Posted 6 years ago #

    You're welcome and the important thing is that you found the answer. Happy blogging.

  5. PhotoMan
    Member
    Posted 6 years ago #

    My "use visual rich text editor" IS checked - I in fact unchecked it, saved tested my page to see that it was removed. Rechecked it on and saved.. NO change -- It still isn't working.

    Any other ideas? I'm using WP 2.5.1

  6. toffeejay
    Member
    Posted 6 years ago #

    Hi I had the same problem but when i went to the Your Profile page there was no checkbox for me to activate/deactivate the visual editor.....any ideas???

  7. Joris Wenting
    Member
    Posted 6 years ago #

    TINYMCE (Visual Editor) dissapearance SOLVED!!

    Well People,

    After a long night of hard struggle, I found the solution for this annoying problem. I really tried all the routines as described in the other forum posts.

    The sollution is quiet simple. The PHP engine of the hostingserver needs to be resetted, because one way or another it keeps caching the faulty javascript from TinyMCE.

    a way to do this is by temporarily renaming your PHP.ini file, often found in the CGI-Bin folder on your server.

    Step1: as described in the other forums edit the file:

    <yourside>/wp-includes/js/tinymce/tiny_mce_config.php

    change:

    'compress' => true,

    into:

    'compress' => false,

    Step2: Rename PHP.INI (e.g to PHP.INI-)

    Step3: go to <yourside>/wp-admin/page-new.php
    (your Visual Editor should allready be visible if not reset your browsers cache and press reload)

    Step4: Restore your PHP.INI file to it's original name.

    Now you can work again!!

    Also a good advise would be for more comfort in memory usage of WordPress to edit the parameter: 'memory_limit' in PHP.ini, which by default is set to 8Mb which is way too low for such an advanced engine. changing it in to 32M (so not Mb!!!!) will be enough for running all your favourite plugins smoothly without annoying hang-ups.

    example:
    memory_limit = 32M;

    Good luck!!

Topic Closed

This topic has been closed to new replies.

About this Topic