WordPress.org

Support

Support » How-To and Troubleshooting » WYSIWYG is killing me

WYSIWYG is killing me

  • I have this

    <img src="http://mysite.tld/files/2007/05/badvista_no_littering.png" alt="Bad Vista" width="100px" align="right" />

    .. and when I save it comes out

    <img src="http://mysite.tld/files/2007/05/badvista_no_littering.png" alt="Bad Vista" width="100px"/>

    completely erasing my align=”right” code.

    Can I do something to stop that behaviour? I already turned off the WYSIWYG editor and I’m using the “normal” editor.

    Is there a third option? Maybe a text entry box? I can’t handle having all of my images aligned left. it’s sad.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You can always disable the wysiwyg. Users -> Your Profile, top checkbox.

    You might also check out this article on working with images.

    I, personally, just define a couple classes in my theme’s stylesheet. I add the image, then add the left or right class to it.

    Users -> Your Profile, top checkbox.

    Yup, had that covered, but it’s always a good thing to double check right? It’s not the “advanced editor”, it’s the “normal” one that does this. The advanced editor is even worse!

    I’m hosting WPMU. I don’t particularly want to edit all of the templates on my site (and each new one I add) and then write up a “how to” for all of my users when align=”right” or align=”left” were programmed into HTML for a reason. I would also have to figure out which templates already have such an option, rip that out, put in a new one that is the same for each template and, and , and …

    This shouldn’t be happening in the first place when a simple text box is all it takes… and blah blah blah I’m ranting about the stupid WYSIWYG again aren’t I? Nobody cares I know. I’m the only one who doesn’t like it… I know. I know… I’ll go sit in the corner with the rest of the special kids.

    I’m hosting WPMU

    Then post in their forum, not here.

    *raises hand* Don’t like it either. Just insert line breaks to get rid of the tedious bit, I’ll handle any other code I might need to put inside posts, thank you very much…

    Then post in their forum, not here.

    I had my reasons for posting here, but thanks for the tip… and such a polite one at that. You’re the best moderator in the whole wide world.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WYSIWYG is killing me’ is closed to new replies.