Support » Plugin: Ecwid Ecommerce Shopping Cart » wysiwyg error from Ecwid

  • Resolved morktron

    (@morktron)


    Hi, I have a client who is saying they can’t use a few of the WYSIWYG features including ‘add media’ and ‘add products’, also toggling between visual and text mode doesn’t work.

    I can’t replicate the error my end, however, I did see an error in Google Chrome dev tools console:

    Deprecated TinyMCE API call: <target>.onInit.add(..)

    This comes from: …/wp-includes/js/tinymce/plugins/compat3x/plugin.min.js

    I narrowed this error down to the Ecwid plugin by duplicating the site and testing all the plugins one by one.

    Just to be sure I installed a local fresh copy of WordPress with the 2017 theme and no plugins enabled except Ecwid. The same error is still there.

    I’m waiting to hear back from my client to see if deactivating the Ecwid plugin resolves the issues. Meanwhile is it possible that this error is the cause of the WYSIWYG issues?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi @morktron,

    I just tried the same on my computer — I installed a fresh WordPress (the newest version), add the Ecwid plugin and tested both pages and posts editor in the WordPress admin backend. But I didn’t encounter any trouble with adding a media or switching between text/visual modes. Also, the browser console didn’t display any error messages to me.

    Can you please describe your environment in more detail? Do you download WordPress from the WordPress.org site or use some kind of quick WP launcher on your hosting? Could it be that your copy of WordPress using some other WYSIWYG editor? Are you using the latest WP version?

    Thanks,

    Thread Starter morktron

    (@morktron)

    Hi @makfruit, thanks so much for getting back to me. I wasn’t able to duplicate the issues myself, only the error.

    Just to be sure I’ve installed a completely fresh version of WP and have done it the standard manual way, without any launcher. My local server is a Synology server.

    Here is a screen shot:

    The same issue appears on Siteground servers, so I assume it is not specific to the server environment – but I could be wrong.

    My client confirms that when Ecwid is disabled then the WYSIWYG functions as normal.

    I can give to a copy of the site if you want to troubleshoot it?

    Thanks for the details. Now I see the “deprecate” message myself — it turns out to be a notice which didn’t display when I filter the dev Console messages by errors/warnings. That said, the message shouldn’t actually impact any functionality as that is not an error actually. Rather is that a code recommendation.

    We will fix that anyway to make sure it doesn’t appear and affect anything.

    As to the issue on your customer’s computer, can you ask them what browser and OS they use? We will try to reproduce it in that environment.

    Thanks

    Thread Starter morktron

    (@morktron)

    Ok great thanks Makfruit, yes it all seems to work fine for me, so maybe that error is a wild goose chase.

    I shall find out what browser and OS they are using and get back to you soon, cheers

    Okay, thank you!

    Thread Starter morktron

    (@morktron)

    Hi Makfruit, my client is using Safari Version 10.1.1 (10603.2.5) on Mac OS X Yosemite
    Version 10.10.5. She’s tried Firefox as well but still has the same issues.

    I’ll keep trying to find more info…

    Hi @morktron,

    Thanks for the details. Just tried it in the same Safari version on MacOS Sierra. The OS version is unlikely the reason though.

    To be honest, I am out of suggestions. Would it be possible for you to reach out to us at support[at]ecwid.com and provide an access to the WordPress admin backend so we can try it ourselves in the customer WP admin?

    Thread Starter morktron

    (@morktron)

    Thanks Makfruit, I’m also bamboozled by this one! Sure I will contact ecwid support direct. Thanks again for your help

    Hi @morktron,

    This is a follow up on
    > We will fix that anyway to make sure it doesn’t appear and affect anything.

    We fixed those warning messages in the browser console — they should not appear anymore. Please update your plugin to get the fix applied.

    Thanks,

    Thread Starter morktron

    (@morktron)

    Thanks Ecwid, that is great, I’ve updated the plugin now and will see if my client still has issues. She’s away on holiday now but I’ll check when she gets back.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wysiwyg error from Ecwid’ is closed to new replies.