Support » Fixing WordPress » WYSIWYG Editor-Youtube video embed problem

  • im having problems with the editor and posting youtube.com videos The embed code.

    I past the code in the code view and it works if i switch to the WYSIWYG editor some of the code disapears this happens in both Firefox and IE 7. IE 7 seems better with the editor than firefox. Ive turned of the WYSIWYG editor due to the problems.

    Take this code from youtube

    <object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/9Jo_OcXTGSY"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/9Jo_OcXTGSY" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350"></embed></object>

    If i switch to visual view and back to code view i get:

    <object width="425" height="350">
    <param name="movie" value="http://www.youtube.com/v/9Jo_OcXTGSY"></param>
    <param name="wmode" value="transparent"></param></object>

    I assume this is a bug or browser problem?

Viewing 15 replies - 1 through 15 (of 21 total)
  • WDavidStephenson

    (@wdavidstephenson)

    I have a slightly different problem (although I do find that sometimes part of the code disappears): I can embed the video when I do it on my desktop version of WordPress, but when I transfer it online, the video is transferred from my post to the sidebar!

    jonchattman

    (@jonchattman)

    I am using a new template and for some reason my embedding feature isnt working – meaning all my embedded youtube videos and photobucket photos arent working – can you email me if you get this if you know what might be wrong- jonchattman@aol.com
    thanks!
    it’s semi urgent

    Darran

    (@darran)

    When posting youtube videos, switch to code view because the visual editor makes some changes to your post which you are unaware of. The code view is the way to go!

    mommasteph

    (@mommasteph)

    I use the code view to paste in the YouTube embed code, and it works initially when I preview the post, but if I save and reopen the post, the code is changed.

    Here’s how it looks after I paste it in:

    <object width=”425″ height=”350″><param name=”movie” value=”http://www.youtube.com/v/Ocf11DfJ0GI”></param><param name=”wmode” value=”transparent”></param><embed src=”http://www.youtube.com/v/Ocf11DfJ0GI” type=”application/x-shockwave-flash” wmode=”transparent” width=”425″ height=”350″></embed></object>

    Here after I save and reopen:

    <object height=”350″ width=”425″>
    <param name=”movie” value=”http://www.youtube.com/v/Ocf11DfJ0GI”></param>
    <param name=”wmode” value=”transparent”></param><ibed type=”application/x-shockwave-flash” wmode=”transparent” width=”425″ height=”350″></ibed>

    </object>

    Notice the embed source is gone.

    Any ideas?

    Darran

    (@darran)

    Try disabling the visual editor when you paste the code, chances are that you view it in the visual editor, it edits the code for you.

    IanC

    (@ianc)

    I had this issue with 2.2 ecen if I added the code under the code tab.

    However in 2.3 this seems to have resolved itself. I added the hmtl code under the code tab and then went to visual editor and then went back under the code tab and all the coding is still there.

    http://w3.try-streaming-video.com/?page_id=6

    njoker555

    (@njoker555)

    where did you go to turn off the WYSIWYG editor? i have the same problem and cant seem to fix it

    IanC

    (@ianc)

    Hey there

    Log in to admin, go to users, choose your profile and the little tick box is right at the top. Just untick it.

    mrkingid

    (@mrkingid)

    Just use the ‘viper video tags’ plugin. solves your issue.

    njoker555

    (@njoker555)

    yea did that, found it in faqs, doesn’t seem to fix the problem :/

    gonnna look up that viper video tag plugin

    gilliancs

    (@gilliancs)

    http://wordpress.org/extend/plugins/easytube/

    If you just want to use youtube or googlevideos this plugin is really simple.

    From the plugin page:

    A wordpress player can be embedded in a post using a tag of the following form:

    [youtube:URL]

    e.g. [youtube:http://www.youtube.com/watch?v=Jb1_h9bguvI%5D

    The URL is the url found on YouTube for a particular video.

    You can also set the dimensions:

    [youtube:URL WIDTH HEIGHT]

    e.g. [youtube:http://www.youtube.com/watch?v=Jb1_h9bguvI 300 200]

    Same tag format for Google Vidoes but with googlevideo instead of youtube e.g. [googlevideo:URL]

    mattbaehr

    (@mattbaehr)

    I found that if I post the code it works fine. Then, if I go back in and change any part of the post, it changes my code and the video can’t be seen.

    <embed src="http://eyespot.com/flash/flvplayer.swf?contextId=11&vurl=http%3A%2F%2Fdownloads.eyespot.com%2Fplay%3Fr%3D0XCzIG2UEjhR9HiEJW0nIWgR4U" type="application/x-shockwave-flash" width="324" height="264"></embed>

    becomes

    <embed height="264" width="324" src="http://eyespot.com/flash/flvplayer.swf?contextId=11&vurl=http%3A%2F%2Fdownloads.eyespot.com%2Fplay%3Fr%3D0XCzIG2UEjhR9HiEJW0nIWgR4U"></embed>

    I’m not sure if this is the same problem, as I’m not embedding YouTube code specifically, but just some object/embed tags.

    In any case, when I publish, the object/embed tags don’t seem to end up in the right place in HTML. They appear outside the “entry” div and because of this they seem to hose the rest of the page’s CSS.

    Is this a bug, or a feature? Either way, is there some way to work around it? Embedding iframe tags seems to work as expected.

    I had problems embedding YouTube videos on my site too, so I wrote this article (it’s probably nothing new, but it solved my problem):

    http://www.michaellundberg.com/2007/11/25/how-to-post-youtube-videos-in-wordpress/

    anyone know what happened to this option? http://faq.wordpress.com/2006/07/29/how-do-i-post-a-google-video/

    did this ONLY work for wordpress.com blogs? And if so why can’t we do that same to our custom blogs?

    I’m looking for an easy way for one of my clients to upload her own google/youtube videos to her blog. Thanks!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘WYSIWYG Editor-Youtube video embed problem’ is closed to new replies.