Support » Fixing WordPress » WYSIWYG Editor Suddenly Not Functioning

  • Resolved cUbEnzIz


    A few days ago, the wysiwyg editor on my 3.5.1 WordPress install stopped functioning, seemingly without provocation. I had not just installed any new updates, themes, or plugins as far as I know. When you click on the “Visual” tab, it simply does nothing. This is occurring in both Chrome and Firefox.

    I have tried swtching themes (switched to 2013 with no effect) and deactivating all plugins (except Maintenance Mode, because it is a high traffic domain). I even tried adding my html/js widgets to Unused. Cleared cache after each change. This has had no effect.

    I followed the JavaScript Diagnostic instructions found here:, including adding define(‘SCRIPT_DEBUG’, true); to the wp-config and viewing the Javascript console in Chrome on a Post page. These were the results:

    Uncaught TypeError: Cannot call method ‘add’ of undefined — post.php1172
    Uncaught TypeError: Cannot call property ‘canvas’ of undefined — load-scripts.php.45

    Does anyone know why this might be happening? Please let me know if there is any additional information I can provide.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Try putting this in your wp-config.php (above ‘stop editing here’)

    define('CONCATENATE_SCRIPTS', false);

    more info:


    Thank you for your reply. However, this had no effect at all. The problem persists.

    The same Javascript errors are present.

    Please let me know if you have any additional troubleshooting ideas.

    Thank you!

    I was finally able to solve this problem.

    To be clear, I tried just about every solution to this that I could find. The most common and seemingly most effective (for 3.5.1) being just manually re-uploading the WordPress core files to override anything that may not have installed correctly with the auto upgrade.

    Solution (for me): I created a new user with admin privileges, logged out and logged in as the new user, and cleared the cache. Vioala! Works like normal now.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WYSIWYG Editor Suddenly Not Functioning’ is closed to new replies.