Support » Installation » WYSIWYG Editor not working after upgrade to 3.0.1

WYSIWYG Editor not working after upgrade to 3.0.1

  • Hey,

    Title says it all, i just got my hands on an older website i want to update for some friends and when i upgraded automatically to 3.0.1 my visual editor is now gone in pages and posts.

    Plugins seem fine, i activated/deactivated and played around.
    Theme is not the problem either, checked that.

    Is there something wrong with the installation or JS?

    Any help would be awesome! Thanks

Viewing 15 replies - 1 through 15 (of 24 total)
  • What version did you upgrade from?

    Can you try a manual upgrade? It’s possible not all the files got overwritten correctly, and you may need to delete the wp-admin and wp-includes files to force the new ones up.


    I re-uploaded WP manually which did nothing, then i deleted the wp admin and includes and replaced them and still nothing.

    Any other ideas?


    Thanks for the help so far.

    Im an idiot for not trying this earlier, but it works with IE..

    So maybe its a problem with the theme?

    I am having this problem in both chrome, opera, firefox and IE so its not a browser/theme issue (i tried changing theme)…had it on two blogs but now one has corrected itself (!) so maybe the other one will as well…let’s see

    It could be a problem with a plugin. They have the ability to goober admin side.

    I am having the same problem, and it’s not a plugin for me. I deactivated them all and still didn’t have a WYSIWYG editor. Also, text is white on old posts.

    I’m thinking it’s a server issue. In fact, I’m pretty darn sure. 5 of my blogs are on one server, and they don’t have the editor. I have one blog on a different server and the editor is working just fine.

    something with php?

    I’m having the same issue- Safari, IE, FireFox. Visual editor bug. The editor initially loads, you see the toolbar and then it disappears. You can click on HTML editor and the toolbar appears but when you click over to visual, the html code stays but the toolbar disappears.

    Anyone got any help? This seems to be a known issue with no known fixes that I can find. Been scouring the interwebs for days!!

    Any help is appreciated!

    Moderator James Huff


    tylerheon, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Ten theme to rule-out a theme-specific issue (theme functions can affect the admin panel).

    If you need further assistance, please start your own topic.

    I am using Thesis 1.8 on WP 3.0.1

    I did all of the above and editor is still not working.

    Activated the Default WP Theme – nothing doing
    Twenty Ten activated and still nothing

    While page is loading the WYSIWYG Editor is visible, but disappears once the page has loaded.

    All text in the edit area is also not visible.

    Is there perhaps any other solution?

    I had a similar problem.

    No Plugins were at fault.

    Theme not at fault.

    Turned out to be a file permissions error – which may account for the comment above on servers.


    thanks for your hint. It sound familiar. But could you please tell us which files/directories and what their permission should be?

    That would really help.

    If you run into the problem where your toolbar disappears from your WYSIWYG editor as well as the WYSIWYG editor not working at all after upgrade to wordpress version 3.1, try this.

    go to your wp-includes/js/tinymce/langs and create a symbolic link to wp-langs-en.js as en.js.

    ln -s wp-langes-en.js en.js

    Looks like someone forgot to rename a file on the upgrade.

    Can you please explain this to a non-programmer? How do you create a symbolic link? Is it a matter of creating a folder or adding a line of code in the file? I have read your solution but do not know what to do with this (ln -s wp-langes-en.js en.js). I use dreamweaver as a passthrough and file transfer only but can edit code if I know exactly where an what to change. – Thanks

    when I upgraded to 3.1.1 my editor was not working so I went in profile and tick
    Disable the visual editor when writing
    and save
    then untick and save that and when clicked on posts I show the editor back so may be I just reset the setting in database.

    I have the same problem

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘WYSIWYG Editor not working after upgrade to 3.0.1’ is closed to new replies.