Support » Fixing WordPress » wysiwyg editor not working?

  • Hi,

    I’m currently using the latest version of WordPress. I’ve recently upgraded from the version below it and I’ve seem to have come across a problem.

    Whenever I go to write a new post, the wysiwyg editor seems to always go into the HTML mode rather than the Visual mode. The reason why this bothers me is I have some people posting on there, who don’t have much knowledge in HTML and need the code to be added for them.

    Is this have to do something with a file broken in the wp-admin folder?

    Alex – PS: If you need a screenshot, just reply here.

Viewing 10 replies - 1 through 10 (of 10 total)
  • First check under your User settings – when you click on your username to edit your profile there is a checkbox at the top that says “use visual editor” – if it’s not checked then you are automatically presented with the code (html) editor…..

    If that’s not your problem post back with a screenshot

    I am also having this problem and my user account is set to use the visual editor.

    This just started happening a few days ago. Nothing has changed. No upgraded or activated plugins since the last time the visual editor worked.

    In fact, the Visual and HTML tabs will indicate a rollover state but will not respond when clicked. It’s just stuck in HTML mode.

    I am having the same problem. Visual Editor tab is selected, but tool bar and editor are HTML. Clicking on HTML tab does not help at all. Any idea how to get the Visual editor back working? This is on RedHat linux. Same installation on the MAC seems working fine.

    Make sure your theme’s functions.php file is well formed. I was able to correct this issue by editing my theme’s functions.php file. Removing blank lines helped.

    Good afternoon, I have the same problem and I don’t know how to solve it. It’s the same with iexplorer and firefox….

    Before installing wordpress 2.7 has gone….

    Pls help me!

    “Use Visual Editor” is ticked on my profile however WYSIWYG editor renders correctly (all editing buttons are available in visual editor) in Firefox but not in IE (only HTML is available) on my laptop. It does however, render correctly in IE on a separate home PC. Laptop is normally networked at work but shutting down at work and restarting off the network at home doesn’t make any difference. Global Policies at work control IE settings but comparing all security and advanced settings on both laptop and home PC show no differences.


    chrisv – There is a difference some where. Your problem sounds like the javascript settings are screwed up. Try making sure to set exceptions for your site in all firewall, anti virus/spyware software, as well as both browsers.

    That usually does the trick for me.

    Another thing that helps me when I have this problem is to re-upload all the .js files for the editor. I usually do the whole includes folder so I don’t miss anything. That usually works well too. js files are sensitive uploaders, don’t know why.

    Thanks for the quick reply but no joy yet. I added site to exceptions but this made no difference. I don’t know where to go for the js files.

    The site appears to be incomplete in its upload in IE on the laptop – status bar reports “Waiting for http: etc …”

    Yeah, that tends to be an ajax or javascript issue. The js files in wp are mostly in the includes folder, that is true for both wp_includes and wp_admin/includes. Try them all. What version of IE are you using on each machine?

    I’m using IE 7-11. Page loading and Visual Editor works in the WordPress blog but not in the Edublogs site which is powered by WordPress. What could make the difference?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wysiwyg editor not working?’ is closed to new replies.