Support » Plugin: Accordion FAQ » WYSIWYG editor errors

  • Resolved jules22

    (@jules22)


    When using the WYSIWYG editor in visual mode the paragraph formatting is not working. For example if I type or paste in the visual editor the following:

    This is my first paragraph

    This is my second paragraph.

    When the accordion opens it displays as follows:
    This is my first paragraph. This is my second paragraph.

    Any paragraph formatting is gone.

    However if I switch to the text editor and I enter html code for example:
    <p>This is my first paragraph</p>
    <p>This is my second paragraph.</p>

    It works fine.

    Thanks, Julian

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having a similar issue. It was working but now all text is in a single block.

    In the Accordion Description the text appears formatted correctly and looks good, with line spaces, etc. But after Updating and refreshing the page (and deleting cache and trying in a different browser), the text is just one block of unformatted words. There are no spaces between lines or paragraphs.

    The text editor in WYSIWYG doesn’t work for me and adding <p> <br> tags etc., has no effect (although <h2> does work). Anything markups added in the Text Editor disappears when the Accordion is updated.

    Plugin Support preetam27

    (@preetam27)

    hi @jules22,

    I have test it and you can put like

    This is my first paragraph
    <br>
    This is my second paragraph.

    in WYSIWYG visual editor mode..it will work

    Thanks.

    jules22

    (@jules22)

    Hi thanks for the response. However you are still relying on the use of html code (<br>) in your WYSIWYG editor. It should not be referred to as a WYSIWYG editor, if one needs to use html code. For me it is not an issue to use html but not for my clients it is.

    davidhaggett

    (@davidhaggett)

    The text editor in the WYSIWYG is now working perfectly for me. I’m able to add HTML and format the accordions exactly as I want. I’m not sure what’s changed but I’m happy it has.

    Plugin Support preetam27

    (@preetam27)

    hi @davidhaggett,

    glad to know your issue has been resolved..please rate our plugin.

    Thanks

    alisontaylorbc

    (@alisontaylorbc)

    As Jules22 has pointed out above, this issue has NOT been resolved.

    Many of us are making websites which our clients will maintain themselves, and the clients usually don’t know HTML. For me to use this plugin (which otherwise looks very good), I would need for the accordion to display the content on the live website with the same formatting that I can see in the back end in the Visual editor.

    As far as I can tell the formatting options work, except one: spaces between paragraphs.

    When entering a new paragraph in the Visual editor, it puts a blank line between two paragraphs in the Text editor. It does NOT put in either <br><br> or <p></p>.

    WordPress usually recognizes those blank lines and displays them on the live website, but your accordion plugin is ignoring them and putting all the paragraphs into one long paragraph.

    It would also be better if the WYSIWYG editor in the accordion plugin always opens with the VISUAL tab selected. Right now, it always opens with the TEXT tab.

    Is this something you will be fixing? I hope so, because I would like to use your plugin in my current project; it has a nice interface in the back end.

    Plugin Support preetam27

    (@preetam27)

    hi @alisontaylorbc,

    we will looking forward to your suggestion..

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.