WordPress.org

Forums

WYSIWYG editor broken (18 posts)

  1. laurentmichel
    Member
    Posted 9 years ago #

    Hi,

    Even though i specify "use visual editor" in Options, i've never been able to activate the WP TinyMCE plugin.

    I must have broken it somehow ... any idea how i could reset it ?

    Thx,
    Laurent

  2. You say you have it selected in Options, but is the box ticked on your user profile page (right at the bottom, easy to miss).

    If that's OK, the next question will have to be what browser(s) are you using, is JavaScript enabled, and any other things you can think of.

  3. billjw
    Member
    Posted 9 years ago #

    I'm having the same issue. No bar at all. I have tried FF and IE. Nothing. All boxes that should be ticked, are ticked.
    Does 2.0 automatically have the editor bar?

  4. laurentmichel
    Member
    Posted 9 years ago #

    Anyone ?
    This issue (no TinyMCE / WYSIWYG editor in WP 2.0) is really annoying. I think I've tried all i could :
    - (un)check relevant boxes : nothing
    - reinstall WP : nothing
    - check for tinymce files : present
    - check with IE/FF : noting
    - check wether javascript is enabled : yes

    What else could it be ???

  5. edasque
    Member
    Posted 9 years ago #

    I have the same problem here. We think our version of php is too old (4.1.2) as the plugin is failing on file_get_contents (requirement is PHP 4 >= 4.3.0, PHP 5)

  6. laurentmichel
    Member
    Posted 9 years ago #

    Thx very much for the tip.

    Strange anyway, my server has php 4.3.10-2 ...

  7. electric
    Member
    Posted 9 years ago #

    I also have the same problem. the "use visual editor" is selected for my users, but none can see the editor. It just shows the OLD quicktags...

    Our server is linux with php 4.3.1.

    Anyone have a fix for this problem?

  8. mattpeckham
    Member
    Posted 9 years ago #

    Same here - it was actually *working* just fine for a time, then suddenly quit.

  9. constantine
    Member
    Posted 9 years ago #

    After upgrading from WP 1.5 to WP2 I'm having No TinyMCE bar at all. All boxes that should be ticked, are ticked.
    A fresh WP2 on the same server solves the issue :-(
    I consider it as an upgrade bug.

  10. ajs279
    Member
    Posted 9 years ago #

    But I had the TinyMCE working on my fresh WP2.0 install for a couple weeks, not it's disappeared. I'm trying to figiure out if installing WPG2 might have screwed something up, but the two plugins were working together OK for several days.

  11. holocron
    Member
    Posted 9 years ago #

    Let me join the chorus.

    WP 2.0.1 installed...not WYSIWYG...

  12. ehersman
    Member
    Posted 9 years ago #

    I too dislike the WYSIWYG feature. I've set up two blogs for friends over the last couple weeks and both of them have problems with the images. One was working just fine, then the next day the images disappeared.

  13. zeinobia
    Member
    Posted 9 years ago #

    I am facing the same problem ,no WYSIWG at all !!
    any quick solution !?

  14. zeinobia
    Member
    Posted 9 years ago #

    sorry for double posting but I found this in the showing details error message in IE
    I think it can b useful for others

    Line :162
    Char:1
    Error:TinyMCE is undefined
    code:0

  15. yashachan
    Member
    Posted 9 years ago #

    I'm having this no visual editor showing up problem, too. I have it set to show in my user settings and it was working fine before I updated to WP 2.0.2 tonight.

    This kind of makes me anxious since I need to get this blog out of my hands and into the hands of the people who are going to run it - and I'm under the impression that they need this to be WYSIWYG. :\

  16. talgalili
    Member
    Posted 9 years ago #

    nothing to add - except - nice to know i am not alone on this...

  17. shoryuken
    Member
    Posted 9 years ago #

    I had the same problem after installing Editor Monkey and then disabling it again. But I managed to get the original TinyMCE Editor back(that one that comes with WordPress by default). As already mentioned earlier. You need to to select TWO options boxes to get the visiual rich editor back. One is at

    "options > writing > user should use the visual rich editor by default"

    and the other one is at

    "users > personal options (at the bottom of users page) > use the visual rich editor when writing"

    Also in Editor Monkey (if you have the plugin installed) you can select the option for deactivating the default editor. Maybe you should try to disable them first (but I guess deaktivating the whole plugin will do the trick also).

    If it still isn't working I can recommend the Editor Monkey plugin - it comes with a more advanced version of the TinyMCE editor.

  18. talgalili
    Member
    Posted 9 years ago #

    Good solution, it worked !

    Although I used the Wysi-Wordpress plugin.

    (and no doabt - you must unactivate the:
    * "options > writing > user should use the visual rich editor by default"
    * "users > personal options (at the bottom of users page) > use the visual rich editor when writing"

    Thanks alot !

Topic Closed

This topic has been closed to new replies.

About this Topic