Support » Fixing WordPress » WYSIWYG & Visual/HTML links not working

  • I don’t know what I’m doing wrong. I’ve checked and unchecked and rechecked the visual editor option, cleared my cache, closed my browser, rebooted, etc. and the WYSIWYG editor is still not working. I do have the Visual and HTML tabs when I post, but when I click on HTML nothing happens. I have a couple of other WP blogs that do not have this problem so I’ve removed the theme, deactivated all of the plugins, etc. and I’m STILL not having any luck. Any other suggestions???

Viewing 5 replies - 1 through 5 (of 5 total)
  • Does anyone have a suggestion?

    I’m having this exact problem. When I go to write a post, the “HTML” options are there (b, i, link, b-quote, etc.), but the “Visual” tab seems to be selected. Clicking on either tab doesn’t do anything, and I can’t figure out how to get the WYSIWYG buttons to come back. Help!

    That’s exactly it!

    My husband mentioned it may be my free godaddy hosting causing it…they put a banner at the top of all pages. I don’t see how this could be but I’ve checked *everything* else. Short of reinstalling WP, I’m at a loss.

    I’m having exactly the same problem. No idea what’s up. I’m hosted on my own server as well.

    I’ve got two websites on there, and the other one that I’m running WordPress on works fine except for the lack of images on the visual editor – but at least I can use it!

    I had a similar problem. Like you, I checked the cache and every other suggestion. I solved the problem on our server. It was because the realpath() function was not working in tiny_mce_config.php. It was due to the permission settings on one of the high level directories on our shared server.

    I wrote a post about it here:
    Visual Editor & TinyMCE Problems with 2.5 – Check realpath() works

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WYSIWYG & Visual/HTML links not working’ is closed to new replies.