[resolved] [WYSIWIYG WIdget] Forces paragraphs instead of line breaks (4 posts)

  1. siriusly
    Posted 3 years ago #

    I'm having trouble with the WYSIWYG plugin forcing paragraph breaks in the text whenever text is updated. Usually, I can go back and delete all of the extra spaces and use "shift_enter" to restore line breaks, and _usually_ that works, but not always. It seems especially problematic on the sidebars, but the same problem exists in the main (center) content area as well. Any suggestions?

    (I've only used this with WP 3.3.1, so I can't say if it worked before that update). The site is http://mentalhealthcrisisalliance.org.

  2. siriusly
    Posted 3 years ago #

    Has anyone else experienced this?

  3. chrisschrijver
    Posted 3 years ago #

    Got the same problem. Simple fix by hacking in the code. Open the file "frontend/WYSIWYG_Widgets_Widget.php" and replace the following line:

    <?php wp_editor($text, $this->get_field_id('text'), array( 'textarea_name' => $this->get_field_name('text'), 'textarea_rows' => 25)) ?>


    <?php wp_editor($text, $this->get_field_id('text'), array( 'textarea_name' => $this->get_field_name('text'), 'textarea_rows' => 25, 'wpautop'=>false )) ?>

    Hope it will fix your problem as well!

  4. siriusly
    Posted 3 years ago #

    Worked! Many thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic