Support » Fixing WordPress » WXR import not working. Also (unrelated?) "edit post," other buttons not working

  • Hello,

    I’m currently trying to consolidate several WordPress blogs into a single network using the new multisite options in WordPress 3.0 and am running into a couple of frustrating difficulties. Would love to hear any insight you have into the issues. Here’s a brief synopsis of the problems. I’m a beginner-level or at least low-intermediate-level user of WordPress, so please let me know if you need any extra information I haven’t provided.

    PROBLEM 1:
    Importing a WXR file from one WordPress installation into another WordPress installation using the plugin WordPress Importer is not working.

    Exporting the WXR file from the first WordPress blog does not seem to be an issue. I have two blogs and have tried it with both, and from what I can tell by looking at the WXR files in TextEdit, they look OK.

    However, when I go to Tools>Import in my test WordPress blog and try to import, the following happens:
    1. I choose “WordPress” from the options list. I’ve already added the WordPress Importer plugin.
    2. On the next screen, I choose “browse” and find the WXR file on my hard drive.
    3. I hit “Upload file and import”
    4. The next screen is blank except for the hammer-and-screwdriver icon and “Import Wordpess” title, as well as the navigation bars on the top and left sides.

    I have tried this repeatedly, with different WXR files and even trying to import into different WordPress blogs. Same thing every time. It’s not an issue of the WXR files being too big – the two I’ve tried are around 650kb and 250kb respectively, well under the posted 8MB limit.

    I have also tried importing the WXR file as an RSS feed. That kinda-sorta works but it would require a considerable amount of cleanup – the photos all point to the old site, many of them also show up as their own posts instead of being in their original posts, and all of my categories are missing (although the category info looks just fine in the WXR file itself). It’s a last-resort option but the amount of hours (weeks, even) to fix that is daunting to say the least.

    PROBLEM 2:
    There seems to be an issue with my WordPress blogs that have the Network feature turned on. I currently have three WordPress installations running. One is a WPMU installation that’s been auto-updated to 3.1.1. The second is a regular, non-WPMU installation that I also recently auto-updated to 3.1.1, and which yesterday I upgraded to a Network. The third is a test installation of 3.1.1, non-networked.

    Here’s the issues:
    On Installations #1 and #2: a) In the Dashboard, the “Incoming Links,” “QuickPress,” “WordPress Development Blog” and “Other WordPress News” sections get stuck on “Loading…” and never actually show any content. b) The “Screen Options” and “Help” buttons do nothing when I click them. The URL changes to “…/#contextual-help” or “…/#screen-options” but the actual sub-window that should pop up does not open. c) Some of the buttons in the “Edit Post” window do the same thing – in the “Publish” section, the three buttons there (Status, Visibility, and Timestamp) don’t work. I can still publish a new blog entry, but cannot change any of the information in the Publish field.

    None of that is an issue with Installation #3. The thing that makes me think it has to be related to the Network feature is that it also wasn’t an issue with Installation #2 until I turned on the Network feature.

    I have tried the standard suggestions of disabling all my plugins and changing back to the TwentyTen theme. That didn’t fix it.

    I have spent several hours trying to find a solution by searching in the forums and on Google for both of these questions and came up empty. Any insight would be greatly appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The thing that makes me think it has to be related to the Network feature is that it also wasn’t an issue with Installation #2 until I turned on the Network feature.

    Since many of us are running networks and do *not* have those issues, then I’d say it’s something particular to your installation or even your host.

    Is this a shared hosting account?

    Things like screen options not working point to javascript conflicts.
    RSS not loading seems like a timeout issue.

    Hi Andrea,

    Thanks for the reply. It’s an Earthlink webhosting account, which I believe does mean it’s shared.

    How could I diagnose whether there are javascript conflicts?

    Hi again,

    No reply to my last question, so I’m re-posting in case my thread has been forgotten.

    How could I diagnose whether there are javascript conflicts or a timeout issue? And what do I do about them? If the issues I’m having _are_ particular to my installation or my host, how can I determine that for certain, and what do I do about it?

    Some hosts actually do checks to see if multisite is enabled and they cripple your install. Yes, really.

    Did you ask Earthlink if they will let you use multisite?

    can you turn off every single plguin and see if the same things happen?

    Have you looked at error logs on the server?

    Thanks Andrea.

    I did try turning off all the plugins, and the same things were happening.

    I had no idea my host might be deliberately blocking multisite. I’ll contact Earthlink and see what they say.

    I haven’t looked at error logs on the server. I will have to ask Earthlink about that as well, because I’m not sure where those would be posted; I’ve never seen any.

    Moderator Jon Cave


    Problem #1 sounds like memory or time limit issues. Having you tried defining WP_DEBUG as true? If you’re able to get hold of some error logs they might shed some light on the cause.

    Thanks Jon, I’ll give that a try!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WXR import not working. Also (unrelated?) "edit post," other buttons not working’ is closed to new replies.