Support » Plugin: WordPress Importer » WXR file error ?

  • Hi, I have used the wordpress importer without any trouble numerous time, but this time, I get this error message.

    Sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number.

    In fact y file is name clinicdacinc.vfb-pro.2013-03-05.xml so I don’t see why I get this message.

    Anyone have any idea ?

    I was able to import the page seperately but when I tried to import all (including the menus, I got this error).

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am having the same issue. I noticed when I installed the plugin on my latest site, it said not tested with the current version of WordPress which would be the latest – 3.5.1.

    Please let us know! thanks!

    The file format doesn’t appear to have changed. Usually this is caused by malformed or invalid XML inside the file. Open the file in your favorite text editor and make sure it starts with:

    <rss version="2.0"
    	<description>Just another WordPress site</description>
    	<pubDate>Thu, 21 Mar 2013 05:23:59 +0000</pubDate>

    or something similar. You can also post it, if you feel comfortable.

    Hi, Thanks so much for responding!

    The two differences I spotted off the bat were the language and the author ID. My file has just ‘en’ as the language rather than ‘en-US’ and no author IDs but that could be a thing as I don’t see a way to determine user IDs in the .com site.

    After thinking for a bit, I ran it through a validator and received this error: 4851: 145 The prefix “atom” for element “atom:link” is not bound..

    I’m not sure how to fix this issue or what it means. From my file:

    <atom:link rel="search" type="application/opensearchdescription+xml" href="" title="What'cha Reading?" />
    	<atom:link rel='hub' href=''/>

    Thank you so much for your help!

    Try using the atom import feature rather than the wordpress one.

    Let’s see what that does.

    I tried that but all it did was import ‘blank’ posts. They all just said “no title” and there was no way to open them, edit them or even any checkboxes to delete them. I had to go in through the database.

    I had to change wordpress themes and the new theme did not recognize all my posts. Interestingly, the website will list the posts as interesting related content but if you click on it (under a new post), it does not exist. So it sort of knows it is there but not how to find it. So I went into the database and am trying to import the posts.I am getting the same error. What fields should I be exporting? I need very basic instructions – please.

    Judging by the ratings and user reports, there are clearly some major issues in the WordPress export/import pipeline right now. What’s even more distressing is how long it’s been broken without getting any attention.

    So please, if this plugin isn’t working for you under standard use conditions, do everyone a favor and mark this plugin as “Not Working”.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WXR file error ?’ is closed to new replies.