Support » Fixing WordPress » ‘www’ getting dropped from address in browser

  • Resolved ljkerley


    I registered my domain as http://www.<domain name>.com. I hosted my domain on GoDaddy. If I input my website into the IE browser address as above, the browser finds the site. However, the address field no longer echos back the ‘www’ part of the address. It just says <domain>.com. This gives the impression my site is not a ‘real’ website.

    I contacted GoDaddy support and they said it was WordPress that was dropping the ‘www’. I need a way to fix this .

    Any suggestions would be appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I know this one. You have to go into your site wordpress admin settings and change the blog url address to include the full qualified address.

    Settings > General Tab

    can you get to your website with and without www?

    If you can, and you just want the browser bar to always show the www regardless of what was typed…

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^(.*)\.domain\.com$ [NC]
    RewriteRule ^(.*)$$1 [R=301,L]

    in your .htaccess should work

    1. You do not register “” you only register “”. The prefix “www” is a fancy sub-domain.

    2. Almost all web hosts set it up in such a way that your domain gets accessed with or without the www prefix.

    3. WordPress does 301 (permanent) redirect to either based on the domain you’ve set as your “Blog URL” in Settings → General.

    This helps in the site not losing its Google search rankings with or without www.


    Thanks to all who replied. It was the setting under Admin. I had assumed that the ‘www’ would automatically be added to the front of the domain. So I see that I assumed wrong.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘‘www’ getting dropped from address in browser’ is closed to new replies.