Support » Plugin: Autoptimize » WSOD (white screen of death)

  • Redpik

    (@redpik)


    Hi,
    I have a white screen of death on many websites (on different servers), appears randomly.
    Strange thing: it appears even if all Autoptimize settings are disabled.
    No server error. Empty DOM. response is 200.
    No bug if I totally disable Autoptimize.
    Thank you for your help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    No errors in the PHP errorlog either?

    But sounds/ smells like a plugin (or theme) conflict redpik, can you disable (and re-enable) other plugins one at a time (and briefly change themes) to try to identify the culprit?

    Redpik

    (@redpik)

    Hi, thanx for your answer.
    – Absolutely no error in logs.
    – problem is on many sites (different themes, different plugins)
    – WSOD appears not every time, maybe once in 50.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Hmm … that doesn’t really make it any easier 😉

    The only things we *know*
    * you see irregular WSOD’s when AO is active
    * this is not something I see on my own sites or on customer’s sites

    What we kind of know (from previous experience):
    * WSOD without info in the error-log most likely is an output buffer conflict

    Now given I don’t see this and given you do, the most logical assumption is that something (and most likely another plugin) is causing OB-conflicts.

    A next step could be for you to set up a test-site with just Autoptimize (with all options off to start with) and see if you still can reproduce the WSOD (which, if my assumption is correct, should not be the case). After that settings can be changed/ other plugins added one at a time to try to identify the conflict?

    Hi,

    I have the same problem.

    – Absolutely no error in logs.
    – problem is on many sites (different themes, different plugins)
    – WSOD appears not every time, maybe once in 5 : more often than you.

    > the white screen appears even if all Autoptimize settings are disabled.
    > If I deactivate autoptimize, everything is ok.
    > If I replace by other minify plugin (like wp-optimize), it’s ok.

    Regards.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I’ll be happy to assist, but the only way forward is an approach similar to the one I mentioned earlier reventlov

    A next step could be for you to [set up a test-site with] just Autoptimize (with all options off to start with) and see if you still can reproduce the WSOD (which, if my assumption is correct, should not be the case). After that settings can be changed/ other plugins added one at a time to try to identify the conflict?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.