Support » Plugin: HubSpot for WordPress » WSOD when installing latest version of the hubspot plugin

  • Resolved Pyro979


    So at some point I updated the hubspot plugin on my server and it caused the wp-admin section to only give me a white screen. I was able to re-activate all other plugins and the admin panel resumed working.

    Things I know:
    Version 1.4.2 works fine.
    Versions 1.5 – 1.5.3 do not.
    It does not work on my production server, but it does work on my local WAMP setup.

    Production Server:
    Apache 2.2.14
    MySQL 5.1.42
    PHP 5.3.6

    Local WAMP
    Apache 2.2.17
    MySQL 5.5.8
    PHP 5.3.5

    I tried debugging as best I could, but I’m not super experienced in debugging these kinds of issues.

    Any ideas? It’s clearly something about the production server, but I’m at a loss for what, and I don’t have any more ideas to go on. I’d be happy to provide more info.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’ll look into this. Another user reported this issue but I can’t recreate it. I’ll post updated when I know something.

    I’ll be more then happy to help you debug.

    Hey Jon, any update on this?

    I’ve taken a couple tries at addressing this issue with no luck. I have another version ready for the next release of WordPress that uses some new features I’m hoping might solve this problem. I might try and release it a bit earlier just so we can see if things are working. Sorry this has been a problem it’s just a hard problem to recreate on my end.

    Yeah, as a developer myself I know how frustrating it is to try to fix an issue that you can’t replicate. If you want me to test drive the new version you can send it to me at

    Hey Jon, I can consistently reproduce the WSOD on Win7 with out-of-the-box XAMPP and a clean new local WordPress install. Let me know if I can test that new version for you. -GG

    I have since uploaded a new version of the plugin with some small fixes I was hoping would fix the problem. It is most likely a memory issue if it is still not working. There are 4 things you can try to fix this:

    1) If you have access to your PHP.ini file you can increase the memory limit directly. Open the php.ini file and find memory_limit and set the value to 64M or 128M if it is less.
    memory_limit = 64M

    2) If you do not have access to the php.ini file then you can also increase the PHP memory limit via your .htaccess file. Open your .htaccess and add the below line to it to increase the memory to 64M or 128M.
    php_value memory_limit 64M

    3) You can also increase the PHP memory limit via the wp-config.php file of your WordPress installation. Open your sites wp-config.php file and search for ‘WP_MEMORY_LIMIT’ if it is there then change the limit size to 64M or 128M, if it is not present then add the below code define('WP_MEMORY_LIMIT', '64M');

    4) If you are still having the problem you, contact your hosting provider and ask them raise your memory limit.

    I’m going to do my best to optimize the plugin over the next few months without sacrificing features.

    no go =c/ this a local install, so I tried all 3. same thing (still only on the admin side though).

    Here is phpinfo, maybe you can see something there:

    maybe it’s some apache mod?

    I’m having this exact issue with a brand new WordPress install on a self-hosted Linux server. The second I activate the Hubspot plugin, the entire admin panel in WordPress is inaccessible — just a white screen.

    WP: 3.3
    PHP: 5.3.6
    MySQL: 5.1.58
    Hubspot: 1.5.5

    I’ve also tried it with WP version 3.2.1 to the same issue. Is there a specific PHP config required? My current configuration is the standard when installed from packages. WordPress _without_ the Hubspot plugin activated works exactly as expected.

    There must still be an issue with this. I was able to install the plugin on our test site but when I install it on our live site, it blows up wp-admin. The only difference that I can tell is the test site has a lower PHP version and is on Windows Server 2008 instead of 2003.

    WP: 3.3
    PHP: 5.3.6
    Hubspot: 1.6.4
    Memory Limit: 128M
    Windows Server 2003

    Any suggestions?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WSOD when installing latest version of the hubspot plugin’ is closed to new replies.