Support » Plugin: WS Form LITE - Drag & Drop Contact Form Builder for WordPress » WS-Form stopped working: wsf_form_json_config is not defined

  • Resolved dejudicibus

    (@dejudicibus)


    Since yesterday WS-Form stopped working. The error on the console is:

    
    Uncaught ReferenceError: wsf_form_json_config is not defined
        at $.WS_Form.get_configuration (ws-form.js?ver=1.4.42:317)
        at $.WS_Form.render (ws-form.js?ver=1.4.42:189)
        at HTMLFormElement.<anonymous> (ws-form-public.js?ver=1.4.42:2539)
        at Function.each (jquery.js?ver=1.12.4-wp:2)
        at a.fn.init.each (jquery.js?ver=1.12.4-wp:2)
        at HTMLDocument.<anonymous> (ws-form-public.js?ver=1.4.42:2530)
        at i (jquery.js?ver=1.12.4-wp:2)
        at Object.add [as done] (jquery.js?ver=1.12.4-wp:2)
        at n.fn.init.n.fn.ready (jquery.js?ver=1.12.4-wp:2)
        at a.fn.init.n.fn.init (jquery.js?ver=1.12.4-wp:2)
    

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter dejudicibus

    (@dejudicibus)

    The problem was solved by adding AFTER the shortcode a block of code

    
      <hr class="dashed" />
      <h3 class="profile">Per accessibilità</h3>
      <p class="profile">
      Nel caso il modulo non funzioni o si abbiano problemi di accessibilità 
      (non vedenti o simili), si prega di scrivere a 
      <a href="mailto:segreteria@romafilmacademy.it" 
      rel="noopener">segreteria@romafilmacademy.it</a>. Grazie.
      </p>
    

    but I have no idea why.

    • This reply was modified 2 years, 1 month ago by dejudicibus.
    Plugin Author Westguard Solutions

    (@westguard)

    @dejudicibus it appears a script on your site called cookiebot is causing the problem. I ran some tests and when I removed that script it allowed the Javascript to run on your pages again.

    If you have any additional questions feel free to contact us directly at support at wsform.com and we can investigate further for you.

    Many thanks!

    Mark

    Thread Starter dejudicibus

    (@dejudicibus)

    Thank you very much. Your support was really precious.

    Plugin Author Westguard Solutions

    (@westguard)

    You are very welcome!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WS-Form stopped working: wsf_form_json_config is not defined’ is closed to new replies.