Support » Plugin: WOW Slider » "Wrong .zip file." any slider update failed

  • Resolved freuter


    Hi Folks and Cracks,

    i hate those “simple solutions”, because most of them produced a lot of trouble. My trouble here:

    I’d inserted an wowslider(4); after the design agency produced a WOW-Slider-File in our header.php at my template path. They uploaded there ZIP-File from the designers Apple OS System into /_wpFlip/wp-content/uploads/wow-slider-plugin/import and added 4 times until anything went right.

    After a while i got somes changes and made them into a windows based System on WOWslider. First, i’d tried to uplaod this ZIP-File as i exported via WordPress-PlugIn into my uploadfolder. The slider name was exactly the same as before. But my installation finished by an alert with “Wrong .zip file.” – same as imported ZIP-Archiv over the import folder.

    So: no way to update it!

    We used WP at latest release in Version 3.8.1 and our WOWslider plugin must be the latest too at Version 4.2 – isn’t it?!

    The whole system works i an Apache-Environment under PHP 5.3.28 so that i think theres no need to change the .htaccess File?!

    a BZip2 Support is available in Version 1.0.6 (from 6-Sept-2010)
    a Zip-Module is enabled too as an Extension Version 1.11.0 and a Libzip at version 0.10.1
    and if it need to know:
    a zlib module is also enabled by zlib.inflate, zlib.deflate
    in a Compiled Version at 1.2.5 and the same as linked Version (so also 1.2.5).

    After all: i get some directories and folders under wp-content/uploads/wow-slider-plugin and it looks like this:

    |   +---images
    |   \---tooltips
    |   +---images
    |   \---tooltips
    |   +---images
    |   \---tooltips

    In my produced HTML-Code all img-Tags located the src-path to /wp-content/uploads/wow-slider-plugin/4/images/ where also located my script.js file <i>-where i found my done changes in-</i>.

    Specially in our case: i had to delete all Image desriptions, renamed all image titles and also killed all links and link targets.

    After i recognized that no upload or update worked, I’d made the changes manually in script.js located at /wp-content/uploads/wow-slider-plugin/4/images/ which are loaded in my slider container like this: <script type='text/javascript' src=''></script>

    Funnily: there is a my title available in cleartext as i’d change it manually. But on frontpage the changed titles for my dots are still the old one (no Proxy, Browser cache deleted – tens of times) and nothing will changed that.

    Before anyone said: “delete all and reinstall it”: i have to understand what’s wrong there. Because i need to know it, if i like to guaranty that any other changes later on will work correctly too.

    There does anyone have a tip or chant for me?

    That’s all for the moment – and thanks for your for your time and attention – in particular thx for your time that is yet to invest for any hint, chant or solution 😉

    At the End just a little hint to any other readers and users who invest there time up to here;-)

    If you just insert a wowslider(X); in your template file, you will get an massive error if the plug-in will be deactivated –
    Unfortunately, this applies to all plug-ins. Whenever you need a call from those plug-ins and before it happend, fix this risk by a simple check if this plug-in is available. Here one possible solution:

    * FCR note:
    * Detects WOWslider plugin first and
    * just inserted if it available and active.
    include_once( ABSPATH . 'wp-admin/includes/plugin.php' );

    // check for plugin using plugin name
    $plugin = 'wowslider/wowslider.php';
    if ( is_plugin_active( $plugin ) ) { ?>
    <?php wowslider(4); ?>
    <?php } ; ?>`

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author


    Images, number of images, links, descriptions, etc. couldn’t cause this error message. This message means that zip file was unpacked incorrectly. Please send us generated file, so we can check it.

    To check if WOWSlider plugin is available, you can use the following code:
    <?php if (function_exists('wowslider')) wowslider(4); ?>

    sendet out – and thanks for your fast reaction
    – respect, my dear, respect!

    … and to all other readers:

    I think I had to revise my speech from the first paragraph above! My harsh judgment on these “simple solutions” (in sense of: “large complex things — greatly simplified”) will be punished by such dedicated and motivated manufacturers as presumptuous and arrogant.

    In this case (and at this plug-in – with those manufacturer)
    is probably an apology attached:
    Sorry – I could not know that I promptly proven otherwise;-)

    Because it had to be simply RIGHT and should be FAIR!

    Plugin Author


    Thanks, we got your module. I tried to install it and got the same error message. Then I opened the archive and found a strange file “install” without filename extension. When this strange file has been removed, I installed your module without any problem.
    One more strange thing with your module. I found “player_mp3_js.swf” and “swfobject.js” files into “install” folder. These files are generated when you add music to the slideshow. But there are no .mp3 file and links to music files in HTML code. If “Play audio file” option isn’t checked and audio file isn’t added, WOWSlider doesn’t generate “player_mp3_js.swf” and “swfobject.js” files.

    Did you make some changes in file manually? If so, please try to publish your slider into empty folder without making changes. If problem will persist, please send us your project file .wowsl and provide us information about your OS. So, we’ll try to reproduce the problem and fix it.

    WOWSlider supports UTF-8 encoding. So, you can use English, German, Arabic, Chinese, Russian, etc. symbols. It couldn’t cause any problem.

    We sent you edited module (without strange file “install”). Please check your email.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘"Wrong .zip file." any slider update failed’ is closed to new replies.