Support » Fixing WordPress » Wrong URL redirects

  • bradyplcmarketing

    (@bradyplcmarketing)


    Hello,

    I am writing regarding an issue I seem to have with redirects. When I type in my browser “bradyplc.com/careers”, it redirects me to the homepage of the website, instead of “https://www.bradyplc.com/careers/”. Is there a way to link the two so that the redirection works? I tried using the redirection plugin, but it doesn’t seem to be helpful.

    I hope that makes sense,

    Best,

    Sarah

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • I clicked the link you provided and it seem to load the careers page for me. I would suggest clearing your browsers cookies and cache. If you do not want to do that try loading it in a different browser or in incognito/private mode.

    bradyplcmarketing

    (@bradyplcmarketing)

    Hello Davood,

    Thank you for your response. Indeed the link works, this is not a broken page issue, but a redirect issue from a browser request. It is when I type in the browser bar on the top of the window “brady.com/careers” (exactly as written) that the link that loads is “https://www.bradyplc.com/”, instead of the “https://www.bradyplc.com/careers/”.

    I hope that makes more sense.

    Best,

    Sarah

    Please take my advice from my last post.

    Clicking the link versus typing it in should make no difference. It should go to the same place whether I type it or click the link provided in your original post, and for me it does. I just tried again typing it manually. It goes to the same place that it went to before when I tried.

    • This reply was modified 1 month, 1 week ago by  Davood.
    bradyplcmarketing

    (@bradyplcmarketing)

    Hello Davood,

    I am sorry, I tried your advice on 3 different browsers (Internet Explorer, Firefox and Chrome), cleared the cache and cookies on Firefox and tried with incognito mode on the two others and it results as the same than experienced before…

    Interesting. A few more things to check

    1) Check in wp-admin under Settings → Reading settings to make sure you do not have the page selected as your Static Homepage

    2) Check in wp-admin under Settings → General to be sure you do not have the page set as the WordPress Address (URL) or Site Address (URL).

    3) Check your .htaccess file to be sure that you do not have a redirect set in there that is redirecting it.

    4) Check your wp-config.php file to be sure the siteurl and/or blog url are not set in there using php.

    If all of that comes up empty let me know and I will draw the attention of others to this thread because I am at a loss if none of that fixes the problem.

    Actually, I do have one other idea. If you have a caching plugin or a CDN set up clear the server side cache as well.

    Then if the problem persists after trying/checking all five of these things let me know and I will draw the attention of others to this thread because I am at a loss if none of that fixes the problem.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.