Support » Plugins and Hacks » [Resolved] Wrong Thumbnail Displayed

[Resolved] Wrong Thumbnail Displayed

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author jureham


    for performance reasons the plugin checks for photos only once so if you added images later it won’t find them.
    To make sure related posts plugin will display the image you want, please use featured image feature in wordpress. Featured images have the highest priority and will always be displayed if set.

    Hope this solves your problem.

    ps. You have a great blog 🙂

    Best, Jure

    So if I change the image at some point it will never see the new image? Is there any way to force it to check again for photos?

    Plugin Author jureham


    For now the only way to set a new image is to set featured image for the post. You can do that by clicking ‘Choose a Featured Image’ in ‘Edit Post’/’Add New Post’ screen.

    I am not using the featured image, nor do I care to. I would rather have this plugin just use the correct image.

    We’ll figure out how to fix this in one of the next releases. I’ll post an update here when we have something!

    (yes, really great blog. hungry now)

    Thanks Rok and Jure! I really like this plugin, and adding an image “refresh” feature would be killer! Good work guys!

    I am having the same issue. I don’t want to use featured image feature because it interferes with my custom template. Is there another way to get around this sample thumbnail issue and have my own first uploaded image to the post be shown as the proper thumbnail?

    My site: http://blog.moonberry.com

    Thank you.

    Sorry for the late answer. We’re fixing this as we go.

    It seems that the images in some of your posts are not “Attatched” to the posts themselves. You can fix this by going to Media – Library and looking for the images that aren’t Attached yet and then attaching them to posts.

    We know this is not optimal and are doing everything to fix it.

    Great blog btw.


    Hey, it looks like you guys fixed this with the latest release! Thank you so much!

    You can always write a review or give us 5 stars 🙂

    Thank you, SOLVED!

    Hi, I have the latest version of the related posts plugin but am still having this problem. For example, check out the following page and scroll to the bottom to see the related posts:

    Mongolian Beef

    The Chinese Orange Chicken and Kung Pao Chicken show pics from the “prep” process in the body of my post instead of the first picture of my post. I don’t know what determines when the correct image is shown versus when it is not – I do everything the same way each time.

    Your help is very appreciated!

    Same problem here.

    What if we clear all the plugin data? Somehow?

    Depends, did you change the post after you published it?


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Wrong Thumbnail Displayed’ is closed to new replies.