WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
wrong tax calculation during checkout (6 posts)

  1. Manege
    Member
    Posted 11 months ago #

    All my product prices are inclusive tax. Tax is applied to all countrys within the EU. During checkout if you set your country within the EU, the total price does not increase and the tax is showing as a line item.

    If the customer choose a country outside the EU, the tax line disappears.

    So far so good but now the problem is the total price stays the same but it supposed to be without the tax.

    For example:
    I have a item in my store for lets say 100 € inclusive 19% tax. I live inside the EU so on checkout the tax line says 16 € and the total price is 100 €. Everything is right.

    However if I choose a country outside the EU the tax line disappears but the total price is still 100€. It supposed to be 84 €.

    Any help?

    Thanks,

    https://wordpress.org/plugins/wp-e-commerce/

  2. whitelamp
    Member
    Posted 10 months ago #

    As far as I know there's no easy solution, which is why I am currently developing a plugin to handle this situation. I'll report back when it's finished and working...

  3. AyeletFleming
    Member
    Posted 10 months ago #

    I have the same problem. Did you manage to solve this issue? Thanks

  4. Justin Sainton
    Member
    Plugin Author

    Posted 10 months ago #

    Hi!

    Thanks for this report - I'd love to get some more information and possibly access to any of your websites where you are encountering these issues. It actually sounds like it may potentially be an issue with the javascript not updating the prices properly.

    Either way, it'd be great to be able to see your configuration and live site to be able to debug further.

  5. Manege
    Member
    Posted 10 months ago #

    Hi Justin, thank you for your help. Please mail me at rainer@epicstudio.de and I give you ftp access to the site.

    Thanks

  6. Manege
    Member
    Posted 10 months ago #

    Does the latest update fixes this issue?

Reply

You must log in to post.

About this Plugin

About this Topic