WordPress.org

Support

Support » Plugins and Hacks » Wrong slideshow plays

Wrong slideshow plays

  • Having a strange problem with the slideshow plugin – created a slideshow and inserted into a page and it worked great. Next created a second slideshow and inserted that into another post. When it was viewed the first slideshow started showing the second slideshow and second slideshow started showing the first slide show – how weird.??!!
    Have tried swapping shortcode but both play the same slideshow and not the one I want on that page…very strange. Has anyone any ideas what I’ve done?
    Many thanks

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Stefan Boonstra

    @stefanboonstra

    Do you have any active plugins that manage, manipulate, control or show posts on your page? This may be affecting the slideshows.

    You could test this by disabling your plugin one by one, until the slideshow displays correctly.

    Hi Stefan, thanks for the reply.
    The only plugin I use that you could be described as managing the posts is ‘marketpress lite’ which is an ecommerce pluging. I don’t want to deactivate this, even for a short while – do you think this plugin maybe the problem?

    The first slideshow works great. (see http://akdfurniture.co.uk) Immediately I publish a second slideshow without even inserting the shortcode anywhere for the 2nd slideshow the first slide show starts showing the pictures of the 2nd slideshow.

    Cheers
    Andy

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi Andy,

    I don’t think MarketPress should be the problem. However, I see that your slideshow is set to ‘randomize’ slides. This could make it look like a different slideshow is showing up.

    With what shortcode do you call the slideshow?

    Best regards,
    Stefan

    Hi Stefan,

    I changed the randomise setting to ‘no’ and still this has the effect of sometimes playing the first slideshow and when the page is refreshed the 2nd slideshow appears..it seems the shortcode has no bearing on which slideshow is played. Anyway I thought the randomise setting refers to the slides within a slideshow.

    I have made 2 slideshows with completely different pictures and shortcode are:
    1.) [slideshow_deploy id=’2161′]
    2.) [slideshow_deploy id=’2196′]

    The problem I’m still getting is that if shortcode 1 is inserted into a post (in this instance on my home page) and then I insert shortcode 2 into another post this causes slideshow 2 to also play on the home page.
    Is there any setting I am missing which will stop this – I want 1st slideshow to appear on my home page every time and not other random slideshows.

    Thanks
    Andy

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi Andy,

    The randomize setting is for slides indeed, I’m trying to make sure I don’t miss anything.

    I’ll see what I can do to solve the problem. It may be an issue caused by the way WordPress gets its posts from the database. You’re not missing a setting.

    I’ve installed MarketPress to see if it’s causing any difficulties, but it isn’t.

    Best regards,
    Stefan

    I’m having this same issue. The slideshows were working great on my development site, and when I moved the install to the live site it started doing this.

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Could you please give me a list of plugins that you have on your live website? I could test if there’s any conflicts between the plugins.

    Hi Stefan,

    Plugins I have installed are:
    Akismet

    All in One SEO Pack

    Dean’s FCKEditor For WordPress

    Exclude Pages from Navigation

    Fast Secure Contact Form

    Google Analytics

    Google XML Sitemaps

    Jetpack by WordPress.com

    MarketPress Lite

    Pinterest “Pin It” Button Lite

    Search Everything

    W3 Total Cache

    WordPress Database Backup

    WP Super Cache

    Andy

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi Andy,

    Thanks for the list of plugins! It would be really great to see Mary Ann’s list of plugins now, perhaps you have matching plugins that cause this issue to arise.

    Best regards,
    Stefan

    Hi Stefan,

    I have:

    • Add From Server
    • Akismet
    • All-in-One Event Calendar by Timely
    • Fast Secure Contact Form
    • Link Manager
    • List Category Posts
    • Search Regex
    • Slideshow
    • Widgets on Pages
    • WordPress Importer

    I’ve noticed that both slideshows are actually playing, but they are playing randomly on both pages with the shortcode instead of behaving and only the one mentioned in the shortcode playing on each page.

    I’m running a custom theme based on Luscious for Genesis if that makes any difference. Weird that it worked perfectly on the development site but not when I moved it (well, reinstalled it – let’s just say the move didn’t go so well).

    Thanks!

    Mary Ann

    Update – I decided to try something different. Instead of using the slideshow shortcode, I put the slideshow widget into Widgets On Pages and selected the correct slideshow for the page. It seems to be working properly when I do that. I’ll let it run for awhile and update if it switches back to running a random slideshow.

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi Mary Ann,

    Thanks for your list as well! I’ll have a look at what plugins could be causing the slideshows to load randomly. I see you’re both running the ‘Fast secure contact form’ plugin, so I’ll have a look at that one first.

    Best regards,
    Stefan

    Plugin Author Stefan Boonstra

    @stefanboonstra

    Hi Mary Ann and Andy,

    I haven’t been able to find the problem yet. I’m very sorry.

    I’ll release version 2.2.8 in a couple of minutes, so I wanted to let you know that it doesn’t included any fixes for the randomized slideshow problem.

    Best regards,
    Stefan

    Thanks, Stefan. I appreciate you working on it. As long as I have a work around (which I do with Widgets on Pages), I’m good until you figure it out.

    Hi everyone, I have the same problem as Andy and Mary Ann. The first slide show worked great but when I added a second show and published it in a different post, the shows started swopping posts. Let’s say I had one slide show with flowers and another with animals posted in two different posts with the corresponding titles. Then the flower slide show often appears in the post titled animals and vice versa. Sometimes the same slide show appears in both posts. This is really a pity because the plugin is easy and simple to use and insert.
    Best wishes,
    Sigrarna

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Wrong slideshow plays’ is closed to new replies.