Support » Plugin: Table Rate for WooCommerce by Flexible Shipping » Wrong shipping calculation after update

  • Resolved Abdul Samad

    (@abdul-samad-k-t)


    Hi,

    Thanks for the wonderful plugin. When we recently updated the plugin to version 4.0.7, the shipping calculation is showing wrong. When I enable debug mode, it shows wrong weights as input (if actual weight is 10 oz for 2 units, it shows 15 oz) when we add more than one product. Here are the rules we using https://prnt.sc/whpd3n ( we are using Skyverge’s latest version of WooCommerce Measurement Price Calculator).

    Please let me know why this is happening. When I am using the previous version 3.16.2, no issues with calculations.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor grola

    (@grola)

    Hi,

    we cannot reproduce this problem. Show us the product measurement settings and cart contents.

    Kind regards,
    Grzegorz

    Thread Starter Abdul Samad

    (@abdul-samad-k-t)

    Hi,

    Here is the measurement settings on the website: https://prnt.sc/wi91gm
    Product weight: 0.6 oz
    I tested the product by adding 10.5 to the cart.

    Here are the screenshots with version 3.16.5
    Product: https://prnt.sc/wi9f3n
    Cart: https://prnt.sc/wi9emy
    Input data for quantity 10.5:
    Cart weight after rounding: 6.3
    Cart value: 18.38

    Here are the screenshots with version 4.0
    Cart: https://prnt.sc/wi9jsg
    Input data for quantity 10.5:
    Contents value: 18.38
    Contents weight: 66.15
    Input data for quantity 10:
    Contents value: 17.5
    Contents weight: 60

    I noticed the issue started from version 4.0. I tested the latest version also. Please check the issue.

    Plugin Contributor grola

    (@grola)

    Hi,

    Please also include a screenshot of the Shipping tab in the product configuration.

    Plugin Support lusp

    (@lusp)

    Hi @abdul-samad-k-t,

    Did you manage to solve the problem you’ve encountered? We haven’t heard from you for more than a week.

    Kind regards,
    Luke

    Thread Starter Abdul Samad

    (@abdul-samad-k-t)

    Hi,

    Please see the screenshot of the shipping tab: https://prnt.sc/x7iucp

    Please let me know if any pieces of information needed.

    Plugin Support lusp

    (@lusp)

    Hi @abdul-samad-k-t,

    Thank you for attaching the screenshot. We are know investigating the problem and trying to reproduce it. We’ll keep you informed on this mater and let you know about our findings sonn.

    Kind regards,
    Luke

    Plugin Support lusp

    (@lusp)

    Hi @abdul-samad-k-t,

    We’ve run numerous tests trying to reproduce the error you’ve encountered, unfortunately with no effect neither using the latest 4.0.8 Flexible Shipping release nor the pre-4.x 3.16.5 version.

    We’ve configured the WooCommerce Measurement Price Calculator plugin, the shipping method and the product the same way you did according to the screenshots you’ve attached. Then we added 21x 1/2 yd product units to have the 10.5 Total Yardage in the cart:

    https://wpdesk.me/ls/f3ltd.jpg

    The Subtotal as well as the shipping cost were calculated properly:

    https://wpdesk.me/ls/1yb82.jpg

    • 21 x $1.75 x 1/2 = $18.375 = ~$18,38 Subtotal
    • 21 x 1/2 x 0.6 oz = 6.3 Total weight -> the rule #1 was triggered giving the $7.50 shipping cost and confirmed in the Debug Mode: https://wpdesk.me/ls/0ym0a.jpg

    The calculation results were exactly the same using the older 3.16.5 Flexible Shipping version before the rules table UI changes:

    https://wpdesk.me/ls/sftsg.jpg
    https://wpdesk.me/ls/iqa23.jpg

    So, as you can see we weren’t able to reproduce it on the fresh WP/Woo installation with only WooCommerce, Flexible Shipping and WooCommerce Measurement Price Calculator plugins installed and active. According to your screenshots the only difference we noticed is that you are using the commas instead of semi-colons in the Length Options field:

    https://wpdesk.me/ls/iyt9i.jpg

    despite the fact its tooltip says the semi-colons should be used there:

    https://wpdesk.me/ls/htrzu.jpg

    However, we suppose it might be an environmental issue caused by some other plugin interfering. Did you update some other plugins lately as well which might have an influence on the calculation in this case?

    Have you checked if the problem also occurs on the Storefront theme when only the WooCommerce, Flexible Shipping and WooCommerce Measurement Price Calculator plugins are active?

    Kind regards,
    Luke

    Plugin Support lusp

    (@lusp)

    Since there are no further inquiries concerning this case I’m marking this thread as resolved.

    Kind regards,
    Luke

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.