Support » Fixing WordPress » Wrong recipient email when there is a new comment

  • Hello everyone,

    Whenever someone adds a comment to a blog article on the website that I have build I recieve an email from WordPress saying that a comment awaits moderation.

    The email is send to my own email address [ redacted ]ed but I would like to have it send to the email address of my client (which is a different email address). So I changed my email to the email address to that of my client in “Settings – General – E-mail Address”.

    The problem is that whenever there is again a comment added to the blog article, the notification email is send to my old email [ redacted ] and not the newly changed email.

    I tried a couple of possible solutions like trying to make a new user with Administrator rights and the email address of my client. Changed all [ redacted ] email addresses in the database. Using the plugin “Better Notifications for WordPress”. Added php code to functions.php. All did not work.

    What can I do in order to get the comment notification send to the right email address?

    Greetings, Rowdy

    • This topic was modified 4 years, 10 months ago by Jan Dembowski. Reason: Don't post email addresses in these forums
Viewing 10 replies - 1 through 10 (of 10 total)
  • I don’t think I can help, but… still… it’s strange to read… No configuration info is stored outside of the database, so are you entirely confident you really searched for all occurences? If none of them are left, it should be entirely impossible for a plugin to still bloody remember your email address… Perhaps, wildcard some of it, or just search for rowdysign.nl in case the @ is encoded differently because Satan? (*cough*)

    Edit: unless https://wordpress.org/plugins/bnfw/ belongs to a company and they rely on their own servers for some operations.
    In all cases, you should contact directly the maintainers of nbfw, it’s them who can fix it in the long term.

    • This reply was modified 4 years, 10 months ago by Sabinooo.
    • This reply was modified 4 years, 10 months ago by Jan Dembowski.

    What is the domain name and what is the email address domain (not the email address, only the part after @) of your client?

    Thread Starter rodricus

    (@rodricus)

    Hello luckychingi,

    The domain name is http://www.matcon.com/blog/ and the email address domain is matcon.com.

    Instead of matcon.com, can you try a generic email address like @gmail.com?

    My guess is that the site is hosted on a shared hosting (webhostingserver.nl) and the MX records on the shared hosting is incorrect. Fixing the MX records in cpanel would help.

    Thread Starter rodricus

    (@rodricus)

    Thanks for your answer.

    I tried a different email address with “@gmail.com” and it worked, it sends an email to that gmail.com address. However it also sends an e-mail to “@rowdysign.nl”, that’s not a big issue but I really would like to have it send to my client’s @matcon.com email.

    sabinooo: thanks for your reply. The e-mail problem did already occur before I installed the nbfw plugin.

    • This reply was modified 4 years, 10 months ago by rodricus.

    Do you have access to cpanel? Check the MX records entry and ensure it matches the real MX record

    0 matcon-com.mail.protection.outlook.com

    Thread Starter rodricus

    (@rodricus)

    Yes I have access to it. The only MX record I see is “matcon.com.” with a value of 10.

    can you change it to matcon-com.mail.protection.outlook.com?

    The value can be left as is

    Thread Starter rodricus

    (@rodricus)

    That could be the solution, however I do not have enough knowledge about changing things like that, cPanel says that making modifications to the MX records can potentially disable all of my client’s email accounts from recieving mail, which would be a big problem.

    @rodricus – the email is hosted on 365 not on the web server.

    You might also need a change to SPF record as under to avoid emails from web server being marked as spam. This needs to be done on the actual DNS for the domain and not on the cpanel

    v=spf1 mx a ip4:141.138.168.152 include:spf.protection.outlook.com -all

    You can test the DNS here:
    https://www.whatsmydns.net/#MX/matcon.com

    • This reply was modified 4 years, 10 months ago by luckychingi.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Wrong recipient email when there is a new comment’ is closed to new replies.