WordPress.org

Forums

Wrong pubDate posted in RSS feed (7 posts)

  1. rookiedesigner
    Member
    Posted 9 years ago #

    I just noticed this problem today, but it seems that WordPress is entering the wrong date for when a post has been published. I tried several times today (April 4th) to post a test and each time the pubDate came out as April 5th.

    Now, the UTC time was actually already on the 5th, but I have -7 filled in for the hours weblog should differ by. It displays the correct time and date on the General Options page, yet still adds the incorrect date into the feed. I keep getting this formatting in the RSS feed:
    <pubDate>Wed, 05 Apr 2006 04:37:40 +0000</pubDate>

    Does anyone know what could be causing this and how to fix it?

    Thank you in advance!

  2. gogela
    Member
    Posted 9 years ago #

    Is your system time accurate?

  3. rookiedesigner
    Member
    Posted 9 years ago #

    Yes it is accurate. Took a look today (on different computer), and tried another test post and now the date seems to be right, but the time is still published as UTC and is not subtracting the 7 hours like I have it setup to do in the Options General settings.

    Any suggestions?
    Thanks!

  4. rookiedesigner
    Member
    Posted 9 years ago #

    Has there been any fix for this problem? I have read numerous posts on the same topic. For each person, the "hours weblog should differ by" are ignored and the posts have a pubdate that is in the future (for California US timezone). This problem seems to go back to version 1. I am using WP version 2!

  5. hoboken411
    Member
    Posted 9 years ago #

    I'm having the same problem. RSS feeds are being published at UTC time and it's ignoring my -4 difference in the control panel.

  6. WordPress always puts the RSS feed date as UTC. The times are stored internally as UTC and only converted for display on the blog. The date it gives is correct, it's just in UTC time. That ain't the future.

    This is not adjustable.

  7. mjfaulkner
    Member
    Posted 8 years ago #

    Okay, explain this... I'm getting a pubdate that predates the invention of RSS. When I try to validate my feed, it says the pubdate is Wednesday, 31 December 1969. Whaaa?

    Here's a link to show you:
    http://www.feedvalidator.org/check.cgi?url=http://feeds.feedburner.com/amandabanana

    It happens on my WP-generated feed before it goes to feedburner. Here's my site:
    http://www.amandabanana.net

Topic Closed

This topic has been closed to new replies.

About this Topic