Support » Plugin: WooCommerce » Wrong product added to the order

  • Resolved elflako

    (@elflako)


    Hi!

    We have a weird problem with our online shop. the problem we have is, when ever someone buys a product, the system adds another product (which i have already deleted from our shop) like 10 times to the order.

    When I look at the order confirmation, you can see 11 positions with the price, but the customer has to pay just one product, so the end price is correct. very weird.

    how can i fix this?

    you can see the order here:

    snipboard.io/LvPtRI.jpg
    snipboard.io/vPQNy4.jpg

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello,

    I can’t seem to see the behavior now that the product has been deleted -https://snipboard.io/Zur9fW.jpg
    But this kind of problem is usually caused by a conflict with your theme or with another plugin. If you can reproduce the issue again, we recommend running a conflict test described here: https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Thread Starter elflako

    (@elflako)

    Hello,

    thank you for the answer, but the products are added AFTER a customer buys.
    so when you put one phone in your cart and you purchase, you get a confirmation mail with your order, and there it happens and it adds these phones 10 times.

    also on the receipt..

    Hello,

    the products are added AFTER a customer buys.

    I see. Have you had a chance to run a conflict test? It’s likely caused by a conflict with your theme or plugin.
    If you don’t want to test on your live site, you can create a staging site using a plugin called WP Staging: https://wordpress.org/plugins/wp-staging/

    Thread Starter elflako

    (@elflako)

    Hi maykato!

    Thank you for your help. I created a staging site and tried everything. Unfortunately, it still shows up!

    Hello,

    I created a staging site and tried everything. Unfortunately, it still shows up!

    Just to be clear, did you switch your theme to Storefront, deactivate all plugins except WooCommerce, and then placed a test order?

    Could you please share a copy of your site’s System Status? You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”.  Once you’ve done that, paste it here in your response.

    We’ve not heard back from you in a while, so I’m marking this thread as resolved. Hopefully, you were able to find a solution to your problem! If you have further questions, please feel free to open a new topic.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Wrong product added to the order’ is closed to new replies.