Support » Plugin: WP REST Cache » Wrong Post add/update flush

  • Anonymous User 18303504

    (@anonymized-18303504)


    Default WordPress posts weren’t cached, so I added them, but custom posts were cached automatically without any additional code implementation.

    I tried testing the caching and it does works but whenever I edit one post in a post type then it flushes the entire cache of that particular post type only. Shouldn’t it flush only a single cached post and the post where it was included?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Richard Korthuis

    (@rockfire)

    Hi @goodhub

    Thank you for using our plugin!

    Your issue is really strange because the default WordPress endpoints (like the one for posts) should be cached automatically and the flushing of those caches upon editing a post should also work out of the box.

    Have you tried disabling all other plugins and returning to a default WordPress theme? It seems like there is some sort of conflict. And which WordPress version are you running?

    Thread Starter Anonymous User 18303504

    (@anonymized-18303504)

    I am using WordPress 5.5.
    I have to add code to the cache posts endpoint.

    Flushing is working but it flushes the entire cache from that particular endpoint.
    I will try with localhost as I am not allowed to disable the plugins.

    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @goodhub

    Did you test it with localhost?

    I just did a test on a clean WordPress 5.5.1 install, with only our plugin installed and activated. It is working as expected: the posts endpoint is cached without any additional code and editing a single post only flushes the caches related to that post.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Wrong Post add/update flush’ is closed to new replies.