Support » Plugin: Remote Content Shortcode » wrong language in embedded Google doc footer

  • Resolved patr100

    (@patr100)


    Hi
    This plug had been working well but with an embedded Google Document I suddenly keep getting a foreign language (arabic?) used for the Google footer statement at the end of a document. Weird.
    See bottom of page on link or see part screen capture at:
    http://imgur.com/SnvEk3L

    I have updated theme, all plugins and translations. No different.

    Please adivse

    • This topic was modified 1 year, 9 months ago by  patr100.
    • This topic was modified 1 year, 9 months ago by  patr100.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi This is still a problem

    Can I get some feedback on this?

    Plugin Author doublesharp

    (@doublesharp)

    @patr100 I’m not sure what is going on, but the plugin is just using curl to request the URL and hasn’t been updated in 9 months. Is it possible the language on the google doc is set to Arabic? In the doc check File > Language.

    • This reply was modified 1 year, 8 months ago by  doublesharp.

    Hi

    No, the language is set correctly to English (United Kingdom)
    Same thing happens with other Google docs I test with the plug in now.

    • This reply was modified 1 year, 8 months ago by  patr100.
    Plugin Author doublesharp

    (@doublesharp)

    What happens if you request the document using curl on the command line?

    I’m not sure how to do that? I’m only using the short code

    eg

    [remote_content url=”https://docs.google.com/document/d/1Arn90KDkAxitPJi8pFjDde3HZCIcUdcd3Ai9fabHpb8/pub”]

    • This reply was modified 1 year, 8 months ago by  patr100.
    Plugin Author doublesharp

    (@doublesharp)

    Curl is a command line utility for fetching webpages. The same library is used by PHP to download the HTMl shown in the shortcode.

    I tried using the same shortcode on a page on my site and it does not have the footer in Arabic. Viewing website you linked above in the same browser *does* does it in Arabic, so my guess is that is related to WordPress/PHP/curl on your system.

    See the test page here:
    https://www.justinsilver.com/annabisset-co-uk/

    Ok Thanks for checking. I don;t think I had the problem
    when I first started using the plug in but I don’t know where to look
    now to try to correct it.

    Plugin Author doublesharp

    (@doublesharp)

    I think I figured it out – because the curl request doesn’t specify a language it is defaulting to Arabic, possibly because it comes first alphabetically? It would be nice if they defaulted to the language specified in the document, but….

    You can use the h1 parameter to specify the language. In an incognito window I was able to change the language at the bottom by alterning the value. Use “en” for english.

    [remote_content url=”https://docs.google.com/document/d/1Arn90KDkAxitPJi8pFjDde3HZCIcUdcd3Ai9fabHpb8/pub?hl=en”]

    Hi
    Thanks for that. Now seems to work OK.
    Weird because only the Google footer was in Arabic
    but not seen the problem any where else.
    A useful plugin as it embeds Google docs without any joins
    or obvious iframes and with a degree of responsiveness
    so it is good to get it working there.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘wrong language in embedded Google doc footer’ is closed to new replies.