• Resolved mbrammer

    (@mbrammer)


    Hello,

    my WordPress is set to German, but the cf7ic is displayed in english.
    Is there a hidden setting to set the correct language?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 31 through 45 (of 63 total)
  • Hi Kyle,

    1. What is your domain (so I can look at your lang attributes): vinicartasegna.it
    2. What is your language set to (exactly as shown in language selection box in settings): Italian
    3. Is your site a multi-lingual site or a single language site: single language (Italian)
    4. Are you using any translation plugins? No

    Further information

    • plugin version: 3.3.5
    • plugin language folder name: “languages

    Regards.

    Hi,
    After looking at your site, it appears that the contact form 7 form’s language is set to English. To fix this, you need to create a new form while your site’s language is set to Italian so that the form adopts the sites language.

    After additional research, I have discovered that the plugin’s translations are working correctly, it appears the issue is with Contact Form 7 itself.

    After looking at the contact forms on sites with translation issues, I found that the language of the Contact Form 7 form is set to English.

    To fix this, you need to re-create your form while your site’s language is set to your desired language output, this will make the contact form adopt the correct language.

    Sorry, didn’t realize I had already responded to this thread, I was on page 1 when responding.

    Thank you for investigating this issue. We had the same problem. I was 100% sure that I had never changed the language to english. But indeed the wp_postmeta > meta_key > _locale was set to en_US. I changed it manually in the database to de_DE and it worked fine.

    For those who have the same issue: Login to your database and change the language setting there for the form post ids. There might an easier solution, but this is for me the best way to go.

    • This reply was modified 1 year, 4 months ago by cutu234.

    Thanks @ktc_88, this worked fine for me. It’s weird because my site has never been set up in English. However, all’s well that ends well!

    Thanks to you too, @cutu234. More technical but faster solution

    Hi, I have one page: http://www.aelter-werden-in-potsdam.de/digital-lotsen-helfen-potsdamern where two different languages are used by cf7ic. How can that be?

    BTW: How can I change the wording i. e. from »Du« to »Sie«?

    The two forms most likely set to two different languages.
    Easiest way to check to inspect your page and look at the two forms to see what it shows in the “lang” attribute of the form.

    To change teh working Due to Sie, you would have to change your site language to Sie.

    How can that be? I have never used a different language on that site!

    In the general settings the site is and was set to Germen (Sie). What else can I do?

    I do not see, where I can change the language of the forms.

    Is it right, when I assume, that the messages of that form should be in the selected language? In both forms the messages are in German!

    There are two language settings in WordPress, one if found under Settings, and the other is in your user profile. You should make sure both languages are set to your preferred language. You will also need to re-create your form as the language is already set to the incorrect language.

    The Image CAPTCHA does not have any control over language settings, they are based off of the language set on the form itself. You can read more about Contact Form 7 language settings on the following link.
    https://contactform7.com/contact-form-in-your-language/

    @ktc_88 Thanks, this helped me. Would be super useful to have a settings page or something with a button to reset the language for all forms to the currently active language! Even though this might be an CF7 issue everything in CF7 works (like validation messages), it’s just this plugin that shows the language incorrectly.

    kevigarvey

    (@kevigarvey)

    I followed all the instructions given, but I am getting an error in Danish language, it shows it in English, I tested it on two sites, could it be a general error in Danish?

    I am experiencing a similar issue. My site’s language ist set to German (de-DE), and the text in the image captcha field is displayed in the correct language. There is however an issue with the red words representing the icons – some of them are displayed in English and some in German.

    I checked my site’s and form’s lang attribute and also created a new form in German. The result stays the same and some of the red words are English, some German. Any help would be greatly appreciated.

    Same problem here.

    Plugin Author hookandhook

    (@hookandhook)

    @kevigarvey @rschach @huuguu

    Thank you for reporting this to me.

    I will have a look and get asap back to you.

Viewing 15 replies - 31 through 45 (of 63 total)
  • The topic ‘Wrong language’ is closed to new replies.