Support » Theme: Blover » Wrong image size chosen for “masonry” miniatures

  • Resolved Piotr Różański

    (@develancer)


    First, thank you for this beautiful template.

    Since yesterday, probably after an update, I experience a problem with wrong size of images displayed as miniatures on the main page. They look good, however, the template chooses to display high-resolution (739×1045) images downscaled to 353×500, despite a version with a correct width (353×499) is also available in wp-content/uploads directory, since I’ve set 353 as the default miniature width.

    Similar issue happens on each single post when displaying the featured image, when the template chooses to downscale 1000×1414 to 739×1044 despite the 739-pixel-wide version is also available.

    Just to clarify: I use WordPress 5.3 and Blover 1.4.1.

    How can I make it select correct images? Thanks in advance.

    • This topic was modified 1 year ago by Piotr Różański. Reason: added version information

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author Patryk Kachel

    (@limestreet)

    Hi @develancer

    images displayed on home page or generally on listing/archive pages have sizes taken from “medium size” settings.
    You may see what we recommend in our docs: https://blogonyourown.com/docs/blover/

    Here I pasted related part:

    Best Image Size in pixels for Blover Theme:

    Thumbnail size: Width 80 – Height 80
    Medium size: Max Width 448 – Max Height 9999
    Large size: Max Width 738 – Max Height 9999
    Custom logo: Height 40

    Please let me know if it helped.

    Best,
    Patryk

    Thread Starter Piotr Różański

    (@develancer)

    Hi Patryk,

    Thank you for such a fast response.

    It helped a bit, now the images are scaled down from 448 to 353. However: why 448? Images on the home page are usually rendered as 353 pixels wide (for wide viewports) or smaller, but on the other hand, they can extend up to 512 pixels for narrow, single column view.

    I still have some problem understanding why the featured image displayed on a single post view (the first image in each post) is taken from the full size and scaled down to 739 pixels instead of using the “large” sized version — even after setting the “large” size to exactly 739 pixels and recalculating.

    Theme Author Patryk Kachel

    (@limestreet)

    It looks like we need to review our recommendations and update them 🙂
    And size of featured image may be a bug. I will take a closer look at the sizes in near future…

    Another way is to use child theme and adjust everything to your needs.

    Best,
    Patryk

    Thread Starter Piotr Różański

    (@develancer)

    I’ll be following the updates, then.

    Also, regarding the recommendations: I’m not sure, but setting the max size to 0 seems to work the same way as 9999, and looks a bit cleaner.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Wrong image size chosen for “masonry” miniatures’ is closed to new replies.