WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Wrong Home Page – No Plugins

[Resolved] Wrong Home Page – No Plugins

  • Quick background:

    Installed through panel into a folder domain.com/home and rewrote a few things to appear in the root. Hated it. Deleted everything and now have a clean install into root through FTP.

    http://texastraditionshome.com

    For some reason, /home-decor is displaying as home. I’ve set it to static fist page and selected the right page. I’ve checked the slugs. I have checked the DB as well, and everything looks right. I don’t know where I went wrong.

Viewing 15 replies - 1 through 15 (of 30 total)
  • I have no plugins installed or running, so it’s not a matter of disabling anything. It’s beyond me why this is happening.

    Can anyone help? I have checked everything I know to check, and it still doesn’t make any sense.

    Moderator kmessinger

    @kmessinger

    Seriously? I mean, c’mon. I’m smarter than that.

    Yes, I’ve selected a static page. In two areas. No matter what I try, I end up either getting the wrong page, or I end up in a reload loop error. I’m using a free theme (Zinnia) to try out. I’ll try throwing a better theme in to try it out.

    Moderator kmessinger

    @kmessinger

    Try it with the 2014 theme.

    I just did a DB reset and then manually wiped all the interior pages. There are no plugins installed or active. There’s essentially nothing. There’s got to be something in the database somewhere that’s calling out ‘home’ when it shouldn’t.

    The original site (DB) was installed on texastraditionshome.com/home and I moved it to the root directory with fresh files and modified the DB. Everything works fine, but creating a home page is creating a loop somewhere.

    Is there any place I can look, or is there someone who might be able to see something I’m missing?

    esmi

    @esmi

    Forum Moderator

    Have you tried reviewing Moving_WordPress?

    I did. Right the fresh install of WordPress in the root folder, and modifying the DB to reflect the SiteURL = domain.com/ instead of /home, everything is running… but the Home page creates a redirect loop. So it either displays a 404, a redirect loop, or it displays a completely unrelated page as ‘home’ – and I cannot figure out any of those events.

    esmi

    @esmi

    Forum Moderator

    modifying the DB to reflect the SiteURL

    That is not sufficient. As you’ll see in Moving_WordPress, you need to run an advanced search & replace tool on the db to change all urls inside serialized arrays.

    I don’t know how to do that.

    I used the web-based version, exported the DB ran it through the site, but can’t import it because it doesn’t naturally overwrite. I don’t know how to import the “cleaned” sql file and have it overwrite the other one.

    esmi

    @esmi

    Forum Moderator

    Try dropping all of the tables and importing the “cleaned” db backup file.

    Okay, how do I do that? I’m in phpMyAdmin right now.

    Sidenote: I also created a new database on the client’s host, but it doesn’t have any tables. If I import that one, can I simply change the wp-config file to the new DB and go from there?

    I’m not really a noob with wordpress… but for the life of me I cannot get DB errors through my head. I apologize for being quite the noob today.

    esmi

    @esmi

    Forum Moderator

    If I import that one, can I simply change the wp-config file to the new DB and go from there?

    Yes – that would be the best option as it leaves the old db untouched.

    I changed the DB name inside the sql file to reflect the new DB I was importing into. Then I went to import it.

    I didn’t work. Thoughts?
    ———-
    Error
    SQL query:


    — Database: txtraditions

    — ——————————————————–

    — Table structure for table wp_commentmeta

    CREATE TABLE IF NOT EXISTS wp_commentmeta (

    meta_id BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
    comment_id BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT ‘0’,
    meta_key VARCHAR( 255 ) DEFAULT NULL ,
    meta_value LONGTEXT,
    PRIMARY KEY ( meta_id ) ,
    KEY comment_id ( comment_id ) ,
    KEY meta_key ( meta_key )
    ) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =1;

    MySQL said: Documentation

    #1046 – No database selected

    —————-

    The new database is there, but there are no tables, no fields, nothing.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] Wrong Home Page – No Plugins’ is closed to new replies.