WordPress.org

Forums

[resolved] Wrong Home Page - No Plugins (31 posts)

  1. alexanderblake
    Member
    Posted 11 months ago #

    Quick background:

    Installed through panel into a folder domain.com/home and rewrote a few things to appear in the root. Hated it. Deleted everything and now have a clean install into root through FTP.

    http://texastraditionshome.com

    For some reason, /home-decor is displaying as home. I've set it to static fist page and selected the right page. I've checked the slugs. I have checked the DB as well, and everything looks right. I don't know where I went wrong.

  2. alexanderblake
    Member
    Posted 11 months ago #

    I have no plugins installed or running, so it's not a matter of disabling anything. It's beyond me why this is happening.

  3. alexanderblake
    Member
    Posted 11 months ago #

    Can anyone help? I have checked everything I know to check, and it still doesn't make any sense.

  4. kmessinger
    Forum Moderator
    Posted 11 months ago #

  5. alexanderblake
    Member
    Posted 10 months ago #

    Seriously? I mean, c'mon. I'm smarter than that.

    Yes, I've selected a static page. In two areas. No matter what I try, I end up either getting the wrong page, or I end up in a reload loop error. I'm using a free theme (Zinnia) to try out. I'll try throwing a better theme in to try it out.

  6. kmessinger
    Forum Moderator
    Posted 10 months ago #

    Try it with the 2014 theme.

  7. alexanderblake
    Member
    Posted 10 months ago #

    I just did a DB reset and then manually wiped all the interior pages. There are no plugins installed or active. There's essentially nothing. There's got to be something in the database somewhere that's calling out 'home' when it shouldn't.

    The original site (DB) was installed on texastraditionshome.com/home and I moved it to the root directory with fresh files and modified the DB. Everything works fine, but creating a home page is creating a loop somewhere.

    Is there any place I can look, or is there someone who might be able to see something I'm missing?

  8. esmi
    Forum Moderator
    Posted 10 months ago #

    Have you tried reviewing Moving_WordPress?

  9. alexanderblake
    Member
    Posted 10 months ago #

    I did. Right the fresh install of WordPress in the root folder, and modifying the DB to reflect the SiteURL = domain.com/ instead of /home, everything is running... but the Home page creates a redirect loop. So it either displays a 404, a redirect loop, or it displays a completely unrelated page as 'home' - and I cannot figure out any of those events.

  10. esmi
    Forum Moderator
    Posted 10 months ago #

    modifying the DB to reflect the SiteURL

    That is not sufficient. As you'll see in Moving_WordPress, you need to run an advanced search & replace tool on the db to change all urls inside serialized arrays.

  11. alexanderblake
    Member
    Posted 10 months ago #

    I don't know how to do that.

    I used the web-based version, exported the DB ran it through the site, but can't import it because it doesn't naturally overwrite. I don't know how to import the "cleaned" sql file and have it overwrite the other one.

  12. esmi
    Forum Moderator
    Posted 10 months ago #

    Try dropping all of the tables and importing the "cleaned" db backup file.

  13. alexanderblake
    Member
    Posted 10 months ago #

    Okay, how do I do that? I'm in phpMyAdmin right now.

    Sidenote: I also created a new database on the client's host, but it doesn't have any tables. If I import that one, can I simply change the wp-config file to the new DB and go from there?

    I'm not really a noob with wordpress... but for the life of me I cannot get DB errors through my head. I apologize for being quite the noob today.

  14. esmi
    Forum Moderator
    Posted 10 months ago #

    If I import that one, can I simply change the wp-config file to the new DB and go from there?

    Yes - that would be the best option as it leaves the old db untouched.

  15. alexanderblake
    Member
    Posted 10 months ago #

    I changed the DB name inside the sql file to reflect the new DB I was importing into. Then I went to import it.

    I didn't work. Thoughts?
    ----------
    Error
    SQL query:

    --
    -- Database: txtraditions
    --
    -- --------------------------------------------------------
    --
    -- Table structure for table wp_commentmeta
    --
    CREATE TABLE IF NOT EXISTS wp_commentmeta (

    meta_id BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
    comment_id BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT '0',
    meta_key VARCHAR( 255 ) DEFAULT NULL ,
    meta_value LONGTEXT,
    PRIMARY KEY ( meta_id ) ,
    KEY comment_id ( comment_id ) ,
    KEY meta_key ( meta_key )
    ) ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =1;

    MySQL said: Documentation

    #1046 - No database selected

    ----------------

  16. alexanderblake
    Member
    Posted 10 months ago #

    The new database is there, but there are no tables, no fields, nothing.

  17. esmi
    Forum Moderator
    Posted 10 months ago #

    You have to select the database in Phpmyadmin first.

  18. alexanderblake
    Member
    Posted 10 months ago #

    Okie dokie. Done.

    I changed the wp-config file to reflect the change but I received this error on the site:

    Parse error: syntax error, unexpected 'FTP_HOST' (T_STRING) in .../wp-config.php on line 31

    Here are the lines before it and line 31:

    /** MySQL hostname */
    define('DB_HOST', 'mysqlv107’); <-- I included this in the paste so you can see it

    /** TR88575 */
    define('FTP_HOST', 'localhost'); <-- this is line 31

  19. esmi
    Forum Moderator
    Posted 10 months ago #

    Try removing that line.

  20. alexanderblake
    Member
    Posted 10 months ago #

    Ugh, another error.

    Parse error: syntax error, unexpected 'DB_CHARSET' on line 31.

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    -------

    It looks like it's just moving down the line with things that are wrong.

  21. alexanderblake
    Member
    Posted 10 months ago #

    Fixed it. Moved some characters around and I'm back in the site on the new DB. Still not giving me the correct home.

    I enter the site URL and it sends me to url.com/home - and I don't know why!!

    BALLS, this is so frustrating.

  22. esmi
    Forum Moderator
    Posted 10 months ago #

    What search & replace tool did you use?

  23. alexanderblake
    Member
    Posted 10 months ago #

    http://pixelentity.com/wordpress-search-replace-domain/

    It was on the Moving WordPress page you referenced earlier.

  24. esmi
    Forum Moderator
    Posted 10 months ago #

    Not used that one myself. Try http://interconnectit.com/124/search-and-replace-for-wordpress-databases/

    That script has worked for me every time.

  25. alexanderblake
    Member
    Posted 10 months ago #

    That's the one I don't know how to use. Do I install those files on the server? What do I do with them? I'm running a mac, so none of them are executable files.

    I guess I upload the folder to the root of the domain, and then navigate there?

  26. esmi
    Forum Moderator
    Posted 10 months ago #

    You need to run it on a web server. I'd suggest running it on a local server.

  27. alexanderblake
    Member
    Posted 10 months ago #

    I did it. I loaded it in and ran it. It made ZERO replacements.

    Is there something else I should be looking for to replace?

    I am trying to eliminate the /home error, but there doesn't appear to be any instances of it in the file.

    This doesn't make any sense.

  28. esmi
    Forum Moderator
    Posted 10 months ago #

    What urls are entered in Settings -> General? Are these fields greyed out?

  29. alexanderblake
    Member
    Posted 10 months ago #

    Both fields are editable and they match.

    http://texastraditionshome.com is entered in both fields.

  30. alexanderblake
    Member
    Posted 10 months ago #

    I keep looking through the DB, hoping to find something I missed. Maybe it's me DNS here. What do you see when you go to the site?

Reply »

You must log in to post.

About this Topic