Support » Plugin: Betta Boxes CMS » Wrong "form action"-url for WP-site in subfolder

  • Resolved andreashallgren

    (@andreashallgren)


    I’m using Betta Boxes for one of my sites, and it worked fine while I was developing the site, but now that it is live I can’t add additional meta boxes.

    I have installed wordpress in i subfolder to my site, i.e. fritsla.se/wordpress/, but the public url is still fritsla.se. Betta Boxes does not seem to recognize this however. When I go to Settings and try to edit an existing Meta Box, the edit-link go to “http://fritsla.se/wp-admin/options-general.php?page=betta-boxes&action=edit-box&id=1”, i.e. the subfolder /wordpress/ is missing from the link.

    And on the Edit metabox page, the form action for the button “Add field” also omits the subfolder, rendering the button useless.

    Is there anything I can do myself to change this? I would like to be able to use Betta Boxes in the future as well, but then I need to find a solution to this problem.

    http://wordpress.org/extend/plugins/betta-boxes-cms/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author shauno

    (@shauno)

    Hi andrea

    The plugin is using WP’s get_bloginfo() method, so it should work if all the URL settings are correct (and I have tested this on a test install inside a subdirectory, and it works).
    My guess is the move has messed something up with a URL.

    I have made a change that should work around this problem though. Please go to this page, and download the ‘Development Version’, under the ‘Other Versions’ heading. Let me know if this solves your problem, and I will release a proper point version.

    Thanks Shauno,

    the development version solved my problem! Great plugin and even better support!

    /Andreas

    Plugin Author shauno

    (@shauno)

    Awesome, glad it worked. I have released 1.1.5 officially now.

    If you like the plugin, feel free to leave a review 🙂

    Consider it reviewed 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Wrong "form action"-url for WP-site in subfolder’ is closed to new replies.