WordPress.org

Forums

Multisite Language Switcher
[resolved] Wrong flag (5 posts)

  1. walther@santis.ch
    Member
    Posted 2 years ago #

    Dear All
    I try to use "Multi Language Switcher". Unfortunately it shows the wrong flag and and the wrong blog and link for translation sites.
    I tried already to remove the plugin and to load it again and started with the english version of my site. The effect was the same. The german flag will lead to the english sites and the american flag will lead to the german sites.
    What do I wrong, or how can I influence which flag and blog is used, or how can I realy remove the plugin. I also saw even after deleting and reloading of the plugin the definitions where still there after activation.

    http://wordpress.org/plugins/multisite-language-switcher/

  2. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    it seems that you should control the settings in wp-admin/options-general.php of every blog. Read on here:

    https://github.com/lloc/Multisite-Language-Switcher/wiki#howto or
    http://lloc.de/msls/3 (deutsch)

    Further a multisite should not have a value for WPLANG in the wp-config.php. You can - of course - decide which flag you want to show. There is the possibility to use a filter for example:

    https://github.com/lloc/Multisite-Language-Switcher/wiki/Change-the-output

    The stable version here at wordpress.org has no deinstaller. This is implemented in the actual developer copy at GitHub:

    https://github.com/lloc/Multisite-Language-Switcher

    Cheers,
    Dennis.

  3. walther@santis.ch
    Member
    Posted 2 years ago #

    Dear Dennis

    Thank you very much for the fast response. I will try to solve it and let you know the outcome.

    Regards,
    Carsten

  4. walther@santis.ch
    Member
    Posted 2 years ago #

    Dear Dennis

    Thanks again. It is now working fine, with setting the wp-admin/options-general.php to the correct language.

    Thanks and best regards,
    Carsten

  5. Dennis Ploetner
    Member
    Plugin Author

    Posted 2 years ago #

    OK, very good!

    Cheers,
    Dennis.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multisite Language Switcher
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic