Support » Plugin: WP Photo Album Plus » Wrong file permissions after Upload

  • Resolved Azragh

    (@azragh)


    Hey there =)

    Our client (fotoverena.ch) informed us that her uploaded photos won’t show up in the generic album anymore.

    We looked after the files and recognized that the file permissions are different to previously uploaded images (the given path is correct, only the permissions were set to 600 insead of 775 – after we changed them manually, they were displayed correctly).

    This issue showed up after the latest WP-Core update (v.4.6.1) and exists in both of the newest plugin versions (6.5.08 and 6.6.00). Screenshot: https://www.dropbox.com/s/hx1o81i7u9gc3ff/wppa_bug.jpg?dl=0

    Are there any settings to solve this problem?

    Many thanks in advance for your help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    No file permissions are set by wppa, so they are inhereted from the folder. Maybe the wp core update set the folder permissions different? 640 should be sufficient.

    FYI: I do not have this issue on any of my sites. Maybe you have an over-active ‘security’ plugin that modifies file permissions?

    Change the folder permissions to 755 ( or 750 ), this should fix it for new files…

    Ok.. This is strange.. We changed/updated the folder permissions manually but this effected only previously uploaded images.. There are no special security plugins too, the only one we’ve installed after setting up wppa is “Yoast SEO” (we deactivated it and tested uploading again – same result)..

    Any other ideas? ^^’

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Yoast SEO is very agressive (=destructive)
    If filepermissions are set, they are no longer default, and will not change when the directory permissions are changed. If the directory settings are set to 755, it should work… for new uploads

    wppa does not set permissions on the files on upload

    wppa sets 755 on directory creations

    Weird.. It should but just doesn’t.. Even if I copy an existing Image from another album into the new one created, the .jpg gets his permissions set to 600.. The images just won’t inherit the folders settings (meanwhile we’ve deactivated all plugins, removed the wppa-theme.php from our child-theme directory but had no luck).

    Screenshot: https://www.dropbox.com/s/2di9iju4o5p6tcf/wppa_img_copy.jpg?dl=0

    So.. I will contact our hoster – maybe there’s an issue somewhere, I don’t know.. =P

    Anyway, thanks for your efforts – After all I can update the permissions manually when our client uploads new photos..

    Hi again – I just wanted to inform you that I retried uploading images this morning, and everything worked fine. I have no idea from where this bug has come from, but I’ll mark this question as resolved. ^^’

    • This reply was modified 3 years, 3 months ago by Azragh.
    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Thanx for your info. But, there is something strange going on. On one of my sites, /upload/wppa/ has rights 755, the files uploaded up to july 27 21:10:20 have rights set to 644, from july 27 21:10:25 until now have 640. So it looks like a sever default that changed. I will ask wp if they do it in core software. However, i will – starting the next version – add chmod() calls to set it explicitly to 640, to avoid this funny behaviour in the future.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Wrong file permissions after Upload’ is closed to new replies.