Support » Plugin: Yoast SEO » Wrong display of the category in breadcrumb after the last update

  • Resolved scorilo

    (@scorilo)


    Hi,
    As I told you in the previous post (May 4, 2020), the error in displaying the breadcrum was not resolved for me.

    I reproduced the situation on a traffic-free subdomain to avoid additional server requests. The update of Yoast and “SEO Data optimization” was done without errors but the breadcrumb displayed is incorrect.
    Posts display a category that has nothing to do with the category / categories in which these posts are included, not being the discussion of a main or secondary category display. Simply, in the new breadcrumb, a completely different category appears from those set in that post. This time no errors appear in the log file (I have enabled debug for wp).
    Just like 5 months ago, if I enter the post, I deselect the categories and reselect, after which I save the post, the breadcrumb appears correctly.
    I can’t repeat this procedure for all posts because there are so many.

    I mention that I updated the Yoast plugin to its latest version (15.1) and I have all the updates made on the site (including the latest version of wordpress).

    I tested the situation even on a default wp theme, to eliminate possible conflicts with my theme, the faulty behavior is the same on the default theme.

    I intend to buy even the premium version of the plugin to get rid of the redirect plugin, but I can’t do that since the data is not displayed correctly in the free version of Yoast.

    What can be the cause of this situation?

    Thank you!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    Please do update to the latest version of Yoast SEO for WordPress 15.1.2.

    Could you then confirm that you’ve already implemented the Yoast SEO breadcrumbs as per here — https://yoast.com/help/implement-wordpress-seo-breadcrumbs/

    Could you then provide us with some screenshots and more details on the breadcrumbs issue you’ve set for one of your posts and where it isn’t showing the correct category in the breadcrumb path?

    Thread Starter scorilo

    (@scorilo)

    Hello,

    Thanks for the reply.

    From what I see the latest version is 15.1.1.
    I also made this update, I implemented breadcrumb correctly in single.php:
    ___________
    <?php if ( have_posts() ) : ?>
    <?php /* Start the Loop */ ?>
    <?php while ( have_posts() ) : the_post(); ?>
    <article id=”post-<?php the_ID(); ?>” <?php post_class(); ?>>
    <?php
    if ( function_exists(‘yoast_breadcrumb’) ) {
    yoast_breadcrumb( ‘<p id=”breadcrumbs”>’,'</p>’ );
    }
    ?>

    <div class=”article-inner <?php …..
    _______________
    I also attached the screnshot (see here LINK SCREENSHOT) with the yoast breadrcumb behavior after the update to 15.1.1. In the attached image (1) I entered breadcrumb with the help of the shortcode, to show that it behaves identically.
    The correct association is in image 2 where I use yoast 13.5.

    Thank you!

    Plugin Support suascat_wp

    (@suascat_wp)

    Hi @scorilo,

    Just to confirm, can you please take the breadcrumb code outside from the WordPress loop of the single.php and paste it in the relevant place, most commonly below the post title? It appears breadcrumb inside the loop is causing the issue.

    Does the issue resolve?

    Thread Starter scorilo

    (@scorilo)

    I tried, no matter where I put it, the behavior is identical.

    I even removed the breadcrump code from any php file and left only the shortcode. Identical, displays incorrectly.

    For testing purposes I installed another SEO plugin (R.M.) which has the same system for entering breadcrumb, ie through php code in exactly the same place where I put the code from Yoast. RM displays my breadcrumb correctly.
    So … it’s not because of where I placed the breadcrumb function. As I said in the previous post, I put on a default wordpress theme, it behaves the same.

    Thank you!

    Thread Starter scorilo

    (@scorilo)

    I mention that this behavior is not valid for all posts. In some it is displayed correctly.
    I couldn’t identify a pattern, that is … what the wrong ones have in common, I checked in detail, there is no pattern.
    Most likely … it behaves as if, at the update, something was not written correctly in the database, but I did the update on a test server, without traffic, with sufficient resources and I did not register errors or warnings (I updated from 13.5 to 15.1.1 with debug true)

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear that you are still having this difficulty with our plugin and it’s must be frustrating for you. We understand that Yoast SEO breadcrumb is showing a completely different category that has nothing to do with the relevant page/post even though everything seems correct as expected.

    In this case, we think this is an issue specific to your setup. So, we’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    We also understand that you want us to resolve the issue for you before you decide to take the premium. However, since we’ll need to take a look at the issue directly on your setup, it is mandatory that you have the premium support that comes with the premium subscription where we can privately investigate the issue further for you.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Wrong display of the category in breadcrumb after the last update’ is closed to new replies.