Support » Plugin: Facebook Thumb Fixer » Wrong description

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Michael Ott

    (@mikeyott)

    Have you tried the Facebook Debugger as mentioned in the help topics?

    Yes, I’ve tried the Facebook Debugger several times, but the “000” still appear and I don’t know why or how to fix this.

    Plugin Author Michael Ott

    (@mikeyott)

    Very odd.

    I can’t replicate this behaviour and I can’t think of a single thing in my plug-in that could cause what you described.

    It’d be impossible for me to troubleshoot without access to your website (you still haven’t even provided a link, so that’s no help :-), which is well beyond the scope of support I’m willing to offer for something I give away for free anyway, sorry to report.

    If you still think my plug-in is the cause I suggest trying an alternative one that does the same thing. This one might help: https://wordpress.org/plugins/opengraph/

    If however, you try a different plugin and still have the same issue, you’ll want to investigate further (it could be your theme is at fault).

    Good luck.

    Oh, you’re right, I forgot the link to my webpage. Here it is: http://www.belenaguilar.com

    This happens when you click on a post and share it in Facebook. I’ve tried Open Graph as you told me but didn’t seem to fix it.

    Anyway, this is a minor problem, I do love your plugin, it works great! I just wanted to know if there was some way to fix this and make the sharing absolutely perfect.

    Thanks a lot for your support and time!

    Plugin Author Michael Ott

    (@mikeyott)

    OK so here’s the skinny.

    If you look at the source code for one of your posts – say this one for example: http://www.belenaguilar.com/2016/08/04/independence-day/

    …search for this meta tag…

    <meta property="og:description" content="900" />

    …which is the issue you are describing, and which you’ll notice appears twice (the second time a few lines further down). And there are other duplicate open graph meta tags but we’ll just focus on this one.

    If I was to take an educated guess I’d say 900 is the post ID whereas it should be the post title.

    But that’s not whats causing the problem, and I am only mentioning it because ideally you don’t want to duplicate your open graph meta tags. It means either you have another plugin outputting open graph meta into the head or – more likely – your theme does it automatically.

    Either way, here’s what we’ve learned.

    1) You don’t need my plug-in or any other plug-in for handling open graph meta if your theme already does that.

    2) If it is true that your theme already has open graph meta output built in and yet the og:description is showing a number, then there is something fundamentally wrong with it or another plug-in is causing it to get ‘confused’. Either way no 3rd party plug-in is going to solve that problem.

    3) You tried another plug-in and got the same result (made no difference).

    4) There’s nothing I or anyone else can do to ‘fix’ this issue. Outside influences – the theme, other plugins, or a combination of both – are causing this issue.

    But here’s some things you can try:

    Disable all plugins and then…

    1) Reload the post and view the source and see if the content of og:description has changed to show the post title instead of a number.

    2) Switch to a different theme – say the default TwentySixteen for example – and repeat step 1.

    3) Switch to a different theme – say the default TwentySixteen for example – activate my plug-in and repeat step 1.

    If the problem persists you’ll need to contact the theme author, or if this is your own work you’ll need to figure out the problem.

    I’ll consider this issue closed as it’s outside the support I can offer. Even if I was to narrow down the cause for you and it was something to do with your theme, obviously I won’t modify the plug-in to accommodate your one specific edge case.

    Good luck.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.