Support » Plugin: Yoast Test Helper » Wrong canonical and URL in source, error with Yoast Test Helper

  • bdd

    (@bws-online)


    I just noticed that in the source for a live site it’s showing the canonical and URL for the related testing site.

    Per other Yoast support posts, I installed Yoast Test Helper and ran the Reset Indexables and Migrations option — only to see errors. (See below.)

    How do I fix this? Thanks.

    Fatal error: Uncaught YoastSEO_Vendor\Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service “Yoast\WP\SEO\Helpers\Indexing_Helper”. Did you mean one of these: “Yoast\WP\SEO\Builders\Indexable_Builder”, “Yoast\WP\SEO\Helpers\Blocks_Helper”, “Yoast\WP\SEO\Helpers\Capability_Helper”, “Yoast\WP\SEO\Helpers\Current_Page_Helper”, “Yoast\WP\SEO\Helpers\Date_Helper”, “Yoast\WP\SEO\Helpers\Environment_Helper”, “Yoast\WP\SEO\Helpers\Home_Url_Helper”, “Yoast\WP\SEO\Helpers\Image_Helper”, “Yoast\WP\SEO\Helpers\Indexable_Helper”, “Yoast\WP\SEO\Helpers\Language_Helper”, “Yoast\WP\SEO\Helpers\Meta_Helper”, “Yoast\WP\SEO\Helpers\Notification_Helper”, “Yoast\WP\SEO\Helpers\Options_Helper”, “Yoast\WP\SEO\Helpers\Pagination_Helper”, “Yoast\WP\SEO\Helpers\Permalink_Helper”, “Yoast\WP\SEO\Helpers\Post_Helper”, “Yoast\WP\SEO\Helpers\Post_Type_Helper”, “Yoast\WP\SEO\Helpers\Primary_Term_Helper”, “Yoast\WP\SEO\Helpers\Product_Helper”, “Yoast\WP\SEO\Helpers\Redirect_Helper”, “Yoast\WP\ in /home/PATH-TO-SITE-FOLDER-WAS-HERE/wp-content/plugins/wordpress-seo/vendor_prefixed/symfony/dependency-injection/Container.php on line 307
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter bdd

    (@bws-online)

    I tried clearing out all caches — didn’t help.

    Wayne Thorley

    (@waynusanus)

    I have the same issue. Did you by any chance find a fix?

    Thread Starter bdd

    (@bws-online)

    Unfortunately, no. Ended up doing a bunch of search and replace tweaks (plugin and manual in the database), and seem to have gotten things cleared out.

    neversaynever504

    (@neversaynever504)

    having same issue. Can we have some help ?

    Wayne Thorley

    (@waynusanus)

    I’ve found that if you have ssh access and wp-cli installed you can reindex using the below command:

    wp yoast index --reindex

    jeroenm77

    (@jeroenm77)

    I have a problem with canonical urls as well. If I run wp_get_canonical_url in my code it gives me the current url instead of the canonical I entered in Yoast page settings.

    I installed the Yoast Test Helper and pushed the reset indexables button, but it gave a fatal error.

    Sort of stuck now :/

    Use Version V 1.9, It is working. 👍There is some problem with the newer version

    mattce

    (@mattce)

    Problem still occurs, would be great, if someone could fix this issue 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.