Support » How-To and Troubleshooting » Writing post fatal error in permalink edit area

Writing post fatal error in permalink edit area

  • Fatal error: Call to undefined function: mb_substr() in /wp-admin/includes/post.php on line 955

    This error appears directly below the post title where the permalink edit link is supposed to be. This was a clean install of 2.7, upgraded to 2.7.1 prior to writing any posts. The first couple of posts were fine and this suddenly started.

    The result is an inability to edit posts because all fields below the error are missing once they are published, yet the quick edit from the main posts page works – allowing changes to the permalink. The error occurs immediately once WordPress does the autosave while you are writing the post, but the fields remain in place – it is only when you go back to edit the post that all fields are missing.

    Pages are fine.

Viewing 8 replies - 1 through 8 (of 8 total)
  • When you upgraded, you might have not uploaded some files.
    You will have to check your install has all the latest files.

    I would agree, except the upgrade was done on a new site before any new posts were made. The first couple of posts were fine.

    I used the auto upgrade option in wordpress.

    Never tried the auto upgrade myself so might be something wrong there. Equally it could be something on the host.

    But you need to check your files still if you want to fix it.

    Line 955 reads:
    $post_name_abridged = mb_substr($post_name, 0, 14). '…' . mb_substr($post_name, -14);

    I uploaded a fresh post.php file from 2.7.1 – didn’t change thing.

    As far as the host is concerned, I have other sites running on the same configuration without issue.

    I believe the issue is actually related to the post titles I’m trying to use. Adding events starting with 2nd annual seems to play havoc with the permalink. If I don’t start it with a number, everything is good.

    thats not the only file you need to upload there are others. I would recommend just putting a complete fresh copy of files on and try that rather than messing around trying to find which file is missint.

    Its not the title starting with a number, I tried and it works fine.

    I will do that and see if it makes a difference.

    I did test numbers vs letters and all posts I start with a number throw the error and all posts that start with a letter do not. Bizarre.

    Thanks for your help. At least if I can’t fix it with the fresh files, I know what to do to prevent it.

    I had the same problem and after googling around found the culprit, the Search Unleashed plugin:

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Writing post fatal error in permalink edit area’ is closed to new replies.