Support » Localhost Installs » write problem for plugins on win10 / localhost

  • Hi,
    I just made a fresh WP install on a localhost server on a laptop running Windows 10.
    I am using XAMMP as an internet server for running the web page with Apache
    When I try to update the only plugin present by default (Askimet) I receive the following message:

    Update failed: Could not copy file. akismet/changelog.txt

    I also tried to install a new plugin, but I get a similar error during installation.

    So it looks like there is some conflict with folders permissions but I don’t know what to do
    after having tried a number of things.
    – first I tried to make sure that I am the owner of the file system where the XAMPP is located.
    – In windows I see that I have full control on the files & folders
    So I don’t really know what else might be wrong
    is it possible that XAMPP has something to do with it?
    The version of XAMPP I am running is 7.2.6
    the version of Windows10 I have is: Windows 10 Home / version: 20H2
    Any help appreciated

Viewing 3 replies - 1 through 3 (of 3 total)
  • When plugins are updated, WordPress looks for the /upgrade folder in /wp-content. If it doesn’t exist or doesn’t have the proper permissions, then the upgrade will fail. If you don’t see the folder at all, just create a blank one called upgrade and then try to update. your plugin.

    Thread Starter sinergyinaction

    (@sinergyinaction)

    Thx for you reply @pbrocks
    I can’t remember what I did, but eventually I managed to update askimet, still there is no

    upgrade

    (or “update” directory)

    Thread Starter sinergyinaction

    (@sinergyinaction)

    Ah ok, now I see an upgrade directory inside the top wp-content folder. Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.