Support » Fixing WordPress » Write Post: Issues

  • Happy Holidays everyone.

    I am having some issues with the Write Post. First of all let me give you my server specifics. I host my own server with this setup:

    Windows XP Pro
    Apache HTTP Server 2.0.52
    MySQL 5.0.17-nt via TCP/IP
    PHP version: 5.1.1
    phpMyAdmin 2.7.0 pl2

    WordPress 2.0.5
    Firefox 2.0 and now as of last night’s upgrade.

    When I go to the Write Post tab in the admin area I will fill out everything like normal; title, content of post, and so forth. My problem occurs when I am ready to do a submit button action be it; save and continue, or save, or publish. When I click either of these buttons the content area of the post gets wiped clean as if it got deleted. Then my tab in Firefox gets stuck or *hangs* on me.

    Please refer to these screenshots on Flickr:

    Figure1: A post ready for publishing

    Figure2: Post content blanks out

    As you can see from the screenshot in Figure2: the progress bar continuously stays busy as if waiting for a page that just refuses to load.

    At this point one of two things happen. It either:
    1. *finally* completes on it’s own or after I hit the reload button several times or I hit the F5 button several times.
    2. it times out on me giving me a WP script error

    In either of those two cases one thing is constant, it waits until the ABSOLUTE laste minute to do anything. According to the script error the timeout limit is 30 seconds, so either it hits the 30 seconds mark and times out or at the 29-30 seconds mark (whether I reloaded/F5 or not) it completes it’s action.

    If it completes the action I all I get for my troubles was a blank tab. See Figure3:

    Figure3: Blank Tab after successful publish

    If I time out I get this script error. See Figure4:

    Figure4: Submit process times out

    What I don’t understand is I never had this problem before and my thinking is, it should be near instantaneous in completing the submit process as it used to be, especially since I am hosting my own server and not having to upload anything.

    Any ideas what can be causing this and possibly what I may do to rectify this issue? Your help is most appreciated thank you.

    Here is the front page of my Flickr I use for hosting images I post to forums.

    Thank you for any consideration you can give me and my problem and have a wonderful holiday season.

    ~~ MAK

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi MAK, long time no hear, sorry you’ve got troubles….

    What did you do JUST before this situation began? Upgrade to 2.0.5? Add plugins? Change themes? Change something in your server setup?

    What’s in the apache error log?

    What’s PHP configured at for max memory?

    Hello vkaryl,

    Well, I upgraded from 2.0.1 to 2.0.5 to be exact and according to the “after-upgrade” print out you get, all went well. I had no errors.

    Hello HandySolo,

    You know, I checked that myself yesterday and didn’t see anything. Yesterday being Dec. 19th when I upgraded and starting having this issue, this is what my Apache error log gave me:

    [Tue Dec 19 10:31:16 2006] [notice] Parent: Created child process 1008
    [Tue Dec 19 10:31:37 2006] [notice] Child 1008: Child process is running
    [Tue Dec 19 10:31:38 2006] [notice] Child 1008: Acquired the start mutex.
    [Tue Dec 19 10:31:38 2006] [notice] Child 1008: Starting 250 worker threads.
    [Tue Dec 19 14:16:31 2006] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Tue Dec 19 16:55:37 2006] [error] [client] File does not exist: E:/My Files/Server Files/_vti_bin
    [Tue Dec 19 23:24:46 2006] [notice] Parent: Created child process 1376
    [Tue Dec 19 23:25:00 2006] [notice] Child 1376: Child process is running
    [Tue Dec 19 23:25:01 2006] [notice] Child 1376: Acquired the start mutex.
    [Tue Dec 19 23:25:01 2006] [notice] Child 1376: Starting 250 worker threads.

    I will go ahead and give from today also.
    [Wed Dec 20 07:48:29 2006] [notice] Parent: Created child process 1460
    [Wed Dec 20 07:48:55 2006] [notice] Child 1460: Child process is running
    [Wed Dec 20 07:48:55 2006] [notice] Child 1460: Acquired the start mutex.
    [Wed Dec 20 07:48:55 2006] [notice] Child 1460: Starting 250 worker threads.
    [Wed Dec 20 16:56:50 2006] [notice] Parent: Created child process 1436
    [Wed Dec 20 16:57:05 2006] [notice] Child 1436: Child process is running
    [Wed Dec 20 16:57:05 2006] [notice] Child 1436: Acquired the start mutex.
    [Wed Dec 20 16:57:05 2006] [notice] Child 1436: Starting 250 worker threads.

    Here is something I just noticed since you had me go back and look at the error log. These four lines below have since Febuary 2006 til December 18th been the same four lines over and over:

    [Mon Dec 18 22:04:02 2006] [notice] Parent: Created child process 1556
    [Mon Dec 18 22:04:22 2006] [notice] Child 1556: Child process is running
    [Mon Dec 18 22:04:23 2006] [notice] Child 1556: Acquired the start mutex.
    [Mon Dec 18 22:04:23 2006] [notice] Child 1556: Starting 250 worker threads.

    I get these same four lines repeated each time, the only thing different is each day or each time the server is accessed, the child # changes.

    The print out I gave for the 19th is when the log starts showing something different, and for today the 20th it seems to be showing the same-old stuff as before. The only thing I did the 19th that I didn’t do today was try and make some posts.

    Anyhow, as far as my non-techie brain goes, this didn’t seem to be related AFAIK. What I actually expected to be the problem was my MySQL database, since everytime you create a post it adds it to the database; but wouldn’t or shouldn’t my database access be almost instantaneous as it has been in the past? I am afterall hosting my own server from my one and only computer, it’s not like I’m uploading megabytes of data here.

    Also HandySolo where exactly do I find out about the PHP memory question you asked me? When things start getting more technical my IQ points go on vacation, so I’m not working with a whole lot at the moment! 😉

    ~~ MAK

    PS: I just saw this thread and another WP user by name of Therseus said the same thing about the tab being blank after a submit.

    “After trying to post a page /wp-admin/post.php comes up blank, does not redirect at all…wich is just lame…since i did a clean 2.05 install less then 2 hours ago.”

    Hello again.

    I saw Moshu reply to a post not long ago and thought I would bump this from a couple hours ago for I still seek an answer I hope will solve my issues. I’ll be going to bed soon so I thought I’d try once more tonight.

    Tomorrow, Dec. 22 is my big 40 birthday so this would be an awesome gift to have my issue solved by then. No pressure haha.

    Thanks all and goodnight. I’ll check back in a few hours.

    ~~ MAK

    PS: @ vkaryl you said, “Hi MAK, long time no hear…”

    I’m sorry but it’s been so long and I am absolutely horrible with names. Do we know each other or are you just in the habit of checking profiles before you reply and you saw that I haven’t posted since ten months ago? Just curious is all.

    And no vkaryl I have not added any plugins nor changed any themes. Bye now.

    Hi again.

    I am bumping this for hopes of maybe getting an answer tonight.


    ~~ MAK

    Hi Moshu,

    Any chance you may have an answer for me about this issue?

    Hi MAK – I just remember you from a while back…. we don’t “know” each other, so to speak….

    I don’t know what to say about the problem you’re having. I would suggest the first thing to do would be to download Mark Jaquith’s plugin that “fixes” some stuff (even though it may not appear that your situation is related to the “stuff” it fixes, can’t hurt!); this is the topic addy, and the download link will be there somewhere too:

    Install and see what happens, then let us know.

    Sorry for responding till now but…
    a) I am not the guy who knows everything; there are many far more knowledgeable helpers around here than I am
    b) probably, I am more of a “traffic director” with an elephant’s memory 🙂
    c) if it is a self-managed server and issues eventually related to it, I never answer the questions because 1) I don’t know anything about servers; 2) it is beyond the scope of this forum to teach wannabe hosts about server setup
    d) if it is not server related, disregard c)
    e) alltogether, it’s very difficult to guess when the problems are in the non-public admin area

    Bumping this again in hopes somebody would have an answer.

    Please, I really need to get this issue resolved! I can’t begin to tell you how annoying this is. Every time I create a new post, or edit it, or save it, or publish it I have to wait upwards of 1.5 minutes each time for it to finally complete the submit. On those occasions when it times out on me, I lose my work and have to re-do it. So that means basically that every time I do a post I have to select all the text, copy it and paste it to Notepad in case this occurs. It’s really a hassle having to do this, and I shouldn’t have to.

    One new thing I discovered and maybe this will make a difference in finding a solution is that I do not have this issue when creating, editing, or publishing PAGES, only posts.

    I would appreciate very much being able to solve this and for any help someone could offer.

    Again I’d like to wish everyone a Merry Christmas and Happy Holidays to you and yours.

    ~~ MAK

    Options -> Writing, what do you have under “Update Services”.

    Does anything change if you clear it?

    Good morning HandySolo.

    Options -> Writing, what do you have under "Update Services".
    Does anything change if you clear it?

    That was something else I was going to ask a couple of questions on, but I prefer to do one thing at a time, trying to get this issue solved first.

    This is what I have for the update services:

    I got all these from somewhere in the Codex.

    Since this was something else I was going to ask about later on, any chance you can please tell me yours?

    OMG DUDE! You’re an absolute GENIUS!!!

    That solved this issue, I tested it a few times making dummy posts then editing them. Was wonderful, got redirects and everything, no timeouts, no pausing, and no blank pages after submit.

    I guess somewhere between February and December 18th when my server was down, some of those services either changed something, stopped working or whatever. So apparently I was getting hung up on that garbage. All I know is I never got hung up on any of that before.

    You are awesome! Now..umm…about your list…hehe You think maybe you can share that with me through here or maybe an email?


    Nevermind this reply here, sorry.

    EDIT: reply deleted by MAK

    Odds are, ONE of those in that list is not responsive and timing out the whole deal.

    One option would be to find one of the “background” pinger plugins. With that the whole Post process wouldn’t have to wait for all the pings to finish.

    What do I use? None!
    I have feedburner managing my feeds. As such, FB checks every 30 minutes to see if anything changed. A side service of FB called “PingShot” then pings all the sites for me.

    No fuss / no muss.

    Alright HandySolo.

    Thanks a ton and have a great holiday season.


    ~~ MAK

    EDIT ADD: For those of you who may be having similar issues as me in this thread, this solved the following things for me:

    It solved the timeouts I was getting and also it solved the no-redirect issue I had (blank page after doing a submit). It also stopped the content area from being wiped out (deleted) when doing a save, or edit, or publish on a post.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Write Post: Issues’ is closed to new replies.