WordPress.org

Support

Support » Installation » [Resolved] Write page doesn’t show Visual editor, just HTML

[Resolved] Write page doesn’t show Visual editor, just HTML

  • I upgraded to 2.5. Everything seems to be working fine. However, I would like to be able to use the new “no-distractions” writing option in the post editor. Unfortunately, I can’t because there is no visual editor tab in the Post editor. The HTML editor tab is also missing, but the Post editor does show the html of the post, and has the old [b][i]… buttons on top. So apparently I’m not in WYSIWYG mode.

    Any ideas on how to get the default editor to show up, instead of this now outdated “Advanced” editor? I tried to change my settings in the Settings, but the “Advanced editor” option no longer exists there.

Viewing 4 replies - 1 through 4 (of 4 total)
  • look in your user profile.

    make sure “use visual editor” is checked. I’ve seen that function get unchecked during upgrades from time to time.

    That was the magic button. I vaguely remember setting that option way back when I first setup WordPress on my site.

    They should probably disable this now that you can toggle between HTML and Visual modes. That, or just have it start in HTML mode by default, but still have the tab for Visual mode if you want to switch.

    Thanks a lot for the help! I never would have found that check box on my own.

    Thanks, srmarketing. I had the same problem.

    Am I right in thinking, though, that which ever you set to be default in the old version, it let you switch between the two on the fly.
    As far as I can tell, if I set HTML to be the default now, it’s not got the option to switch to visual.
    However, if I set visual to be the default, it’s got the option to switch to HTML (and back again).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Write page doesn’t show Visual editor, just HTML’ is closed to new replies.
Skip to toolbar